Bug 1418590 - Container Provider: Image Registries are not collected from Images originating from Openshift
Summary: Container Provider: Image Registries are not collected from Images originatin...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.8.0
Assignee: Erez Freiberger
QA Contact: Einat Pacifici
URL:
Whiteboard: container
: 1422617 (view as bug list)
Depends On:
Blocks: 1419680
TreeView+ depends on / blocked
 
Reported: 2017-02-02 09:38 UTC by Erez Freiberger
Modified: 2018-04-17 11:44 UTC (History)
7 users (show)

Fixed In Version: 5.8.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1419680 (view as bug list)
Environment:
Last Closed: 2017-06-12 17:27:10 UTC
Category: Bug
Cloudforms Team: Container Management
Target Upstream Version:


Attachments (Terms of Use)

Description Erez Freiberger 2017-02-02 09:38:42 UTC
Description of problem:

Image registries that are only referenced from images that are collected from Openshift are not collected. The images will show "unknown image registry" even thought the image registry is in the name.


How reproducible:
Refresh a provider that have a registry referenced only from images known to Openshift and not from images that are on running pods.


Actual results:
The image registry that is only referenced from Openshift will not be collected and presented from those images.

Expected results:
The image registry should be collected.

Additional info:

Comment 2 Erez Freiberger 2017-02-02 09:39:47 UTC
https://github.com/ManageIQ/manageiq/pull/13724

Comment 4 Federico Simoncelli 2017-03-10 09:57:41 UTC
*** Bug 1422617 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.