Bug 1418603 - Lower version packages ( heketi, libtiff ) present in RHGS3.2.0 RHEL7 ISO.
Summary: Lower version packages ( heketi, libtiff ) present in RHGS3.2.0 RHEL7 ISO.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: releng
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.2.0
Assignee: Sreenath G
QA Contact: Byreddy
URL:
Whiteboard:
Depends On:
Blocks: 1351528
TreeView+ depends on / blocked
 
Reported: 2017-02-02 10:27 UTC by Byreddy
Modified: 2017-03-23 06:04 UTC (History)
5 users (show)

Fixed In Version: RHGSS-3.2-RHEL-7-20170209.n.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 06:04:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:0486 normal SHIPPED_LIVE Moderate: Red Hat Gluster Storage 3.2.0 security, bug fix, and enhancement update 2017-03-23 09:18:45 UTC

Description Byreddy 2017-02-02 10:27:02 UTC
Description of problem:
========================

Seeing the lower version of packages in the RHGS3.2.0 RHEL7 latest ISO.

""(older on ISO, newer in yum repos)""
set(['heketi-1.0.2-1.el7rhgs.x86_64',
     'libtiff-4.0.3-25.el7_2.x86_64',
     'python-netifaces-0.10.4-1.el7ost.x86_64'])


Version-Release number of selected component (if applicable):
==============================================================
Latest available RHGS3.2.0 RHEL7 ISO.

How reproducible:


Steps to Reproduce:
===================
1. Install and check the mentioned packages versions and compare packages version with version present in live.


Actual results:
================
Lower version packages ( heketi, libtiff & python-netifaces )  in RHGS3.2.0 RHEL7 ISO.

Expected results:
=================
Latest version should be present

Additional info:
===============
ISO link i will share.

Comment 3 Sreenath G 2017-02-03 05:56:53 UTC
heketi-1.0.2-1.el7rhgs.x86_64 : This is tech-preview version and we need to decide whether heketi build itself is required in ISO & other images (AMI, qcow2 & vhd).

libtiff-4.0.3-25.el7_2.x86_64 was released 2 days back on Feb-1st after the ISO RHGSS-3.2-RHEL-7-20170131.n.1 was created. See [1]. This will automatically get included in next ISO.

python-netifaces-0.10.4-1.el7ost.x86_64 : The reason has already mentioned in BZ#1404541 [2]


[1] https://errata.devel.redhat.com/advisory/26177

[2] https://bugzilla.redhat.com/show_bug.cgi?id=1404541#c10

Comment 4 Byreddy 2017-02-03 06:07:50 UTC
Removed the package "python-netifaces" entry in title based on  https://bugzilla.redhat.com/show_bug.cgi?id=1404541#c10 info.

Comment 5 Sreenath G 2017-02-03 09:21:06 UTC
Agree to bring-in latest heketi-3.1.0-14.el7rhgs (released as part of CNS 3.4) to snapshot 5 spin for RHGS-3.2-RHEL-7

Comment 7 Sreenath G 2017-02-13 11:08:27 UTC
Note: libtiff-4.0.3-27.el7_3 got automatically selected as it was available as an async security update at RHEL-6.8-z on Feb-01

Comment 8 Byreddy 2017-02-14 06:13:35 UTC
ISO mentioned in comment 6 is having correct version of packages(heketi and libtiff)

>ansible-2.2.1.0-1.el7.noarch.rpm
>libtiff-4.0.3-27.el7_3.x86_64.rpm

Moving to verified state.

Comment 10 errata-xmlrpc 2017-03-23 06:04:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2017-0486.html


Note You need to log in before you can comment on or make changes to this bug.