Bug 1418757 - Package list for upgrade checks has to contain only valid packages per version
Summary: Package list for upgrade checks has to contain only valid packages per version
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.1.1
: 4.1.1.2
Assignee: Ravi Nori
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 16:26 UTC by Martin Perina
Modified: 2017-04-21 09:36 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:36:09 UTC
oVirt Team: Infra
rule-engine: ovirt-4.0.z+
rule-engine: ovirt-4.1+
mgoldboi: planning_ack+
mperina: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71730 0 master MERGED engine: Package list for upgrade checks has to contain only valid packages per version 2017-02-09 13:54:29 UTC
oVirt gerrit 72097 0 ovirt-engine-4.1 MERGED engine: Package list for upgrade checks has to contain only valid packages per version 2017-02-13 15:11:34 UTC

Description Martin Perina 2017-02-02 16:26:06 UTC
Description of problem:

In BZ1344020 we have extended package list for upgrade checks significantly, unfortunately we added there packages valid only for 4.0 and some of them don't exists on 3.6 hosts, which always fail "Check for upgrade" flow.

In BZ1405810 we have split package list per version, but unfortunately we have not fixed issues described above for 3.6 hosts.

Version-Release number of selected component (if applicable):

4.0/4.1

How reproducible:

100%

Steps to Reproduce:
1. Install oVirt engine 4 and configure 3.6 DC and cluster
2. Add 3.6 host to this 3.6 DC/cluster
3. Execute Check for upgrades manually or wait for automatic "Check for upgrades" execution

Actual results:

Check for upgrades fails with following error:

  RuntimeError: Package ovirt-imageio-daemon cannot be found

Expected results:

Check for upgrade will not fail always for non-existent package (assuming connection to all repositories is successful)

Additional info:

Comment 2 Lucie Leistnerova 2017-03-06 13:17:17 UTC
upgradecheck on 3.6 and 4.0 host fails with this error

2017-03-06 14:00:12,638+01 ERROR [org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase] (VdsDeploy) [ce717ea] Yum [u'cockpit-ovirt-dashboard-0.9.1-0.0.1.el7ev.noarch requires cockpit']
2017-03-06 14:00:12,649+01 ERROR [org.ovirt.engine.core.bll.hostdeploy.VdsDeployBase] (VdsDeploy) [ce717ea] Failed to execute stage 'Package installation': [u'cockpit-ovirt-dashboard-0.9.1-0.0.1.el7ev.noarch requires cockpit']

tested in ovirt-engine-4.1.1.3-0.1.el7.noarch

Comment 3 Red Hat Bugzilla Rules Engine 2017-03-06 13:17:25 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 4 Martin Perina 2017-03-06 14:33:20 UTC
cockpit-ovirt-dashboard and/or cockpit are NOT in the list of packages to check for upgrade.

@Lucie, could you please try to downgrade ovirt-host-deploy to 1.6.1 on engine machine and try again?

@Sandro, it looks like your fix for BZ1408942 is breaking upgrade of hosts with older cluster versions, could you please fix that?

Comment 5 Lucie Leistnerova 2017-03-06 14:55:00 UTC
I downgraded ovirt-host-deploy to 1.6.0-1 that I have in the previous build 4.1.1-2 and upgradecheck is without error on both 3.6 and 4.0 host.

Comment 6 Sandro Bonazzola 2017-03-07 13:20:06 UTC
The fix causing this regression has been reverted in ovirt-host-deploy 1.6.3 which will be included in next compose 4.1.1 RC3, scheduled in 2 days from now.
Moving this back to ON_QE. Sorry for the issue.

Comment 7 Lucie Leistnerova 2017-03-15 11:39:31 UTC
no errors by upgradecheck for 3.6 and 4.0 host

verified in ovirt-engine-4.1.1.4-0.1.el7.noarch with ovirt-host-deploy-1.6.3-1.el7ev.noarch


Note You need to log in before you can comment on or make changes to this bug.