Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1418900 - [RFE] Include few more options in virt file
Summary: [RFE] Include few more options in virt file
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Krutika Dhananjay
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1418901 1424931 1424932 1424934
TreeView+ depends on / blocked
 
Reported: 2017-02-03 03:35 UTC by SATHEESARAN
Modified: 2017-05-30 18:40 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1418901 1424931 1424932 1424934 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:40:54 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1423442 0 low CLOSED group files to set volume options should have comments 2021-02-22 00:41:40 UTC

Internal Links: 1423442

Description SATHEESARAN 2017-02-03 03:35:56 UTC
Description of problem:
-----------------------
There are some volume options that needs to be added to virt file
network.remote-dio=off
features.shard-block-size=4MB
performance.low-prio-threads=32
cluster.locking-scheme=granular
cluster.shd-max-threads=8
cluster.shd-wait-qlength=10000
performance.strict-o-direct=on
user.cifs=off
nfs.disable=on
cluster.use-compound-fops=on

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
mainline

How reproducible:
-----------------
Not applicable

Steps to Reproduce:
-------------------
Not applicable

Actual results:
---------------
Not applicable

Expected results:
-----------------
Few more options added to virt file

Additional info:
----------------
granular-entry-heal also needs to be enabled on the volume, but this option could only be added unless the volume is started.

Comment 1 Worker Ant 2017-02-09 10:35:12 UTC
REVIEW: https://review.gluster.org/16577 (extras: Add more options to group virt) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Worker Ant 2017-02-10 06:32:35 UTC
REVIEW: https://review.gluster.org/16577 (extras: Add more options to group virt) posted (#2) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 3 Worker Ant 2017-02-10 06:42:22 UTC
REVIEW: https://review.gluster.org/16577 (extras: Add more options to group virt) posted (#3) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 4 Worker Ant 2017-02-17 04:30:37 UTC
REVIEW: https://review.gluster.org/16577 (extras: Add more options to group virt) posted (#4) for review on master by Krutika Dhananjay (kdhananj@redhat.com)

Comment 5 Krutika Dhananjay 2017-02-17 10:15:32 UTC
Why are each of these individual options added?

1. performance.low-prio-threads=32
VM use cases involve more of reads and writes than any other operations. And both of these are categorized as 'low_prio' operations by io-threads. Setting low-prio-threads to 32 saw some improvement in performance in initial testing done by Paul Cuzner.

2. cluster.locking-scheme=granular
This is needed for more granular locking during entry self-heal so that parallel heal-info doesn't hang until heals are complete.

3. features.shard=on
This is needed to reduce heal-times of VM image files which are large files whose size can range anywhere from a few GBs to TBs or even PBs.

4. cluster.shd-max-threads=8, cluster.shd-wait-qlength=10000
These are to leverage multi-threaded self-heal feature to get better heal performance and minimise the effect of downtime on VM file consistency and availability.

5. user.cifs=off
We support access to files in virt use case only through libgfapi and FUSE. So we explicitly disable other methods of access such as cifs.

Comment 6 Worker Ant 2017-02-17 10:44:01 UTC
COMMIT: https://review.gluster.org/16577 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 932ff80b57846ed77b66776ade575a0b2231183a
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu Feb 9 15:56:04 2017 +0530

    extras: Add more options to group virt
    
    Apart from some of the option configurations already listed
    in the group-virt.example file, we also recommend that the
    users set certain other options added by this patch for
    VM use-case. This also helps Gluster-oVirt users in configuring
    virt options for new volumes at the click of a button as opposed
    to setting them manually through volume-set command.
    
    Change-Id: I8524e8d8a06bbbb0b9247571706e786410013b41
    BUG: 1418900
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: https://review.gluster.org/16577
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Sahina Bose <sabose@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 7 Shyamsundar 2017-05-30 18:40:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.