Bug 1418912 - logging stacks can't be deployed by using deployer
Summary: logging stacks can't be deployed by using deployer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Jeff Cantrill
QA Contact: Xia Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-03 06:09 UTC by Xia Zhao
Modified: 2017-07-24 14:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-04-12 19:11:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
deployer_configmap (644 bytes, text/plain)
2017-02-03 06:09 UTC, Xia Zhao
no flags Details
deployer_log (48.48 KB, text/plain)
2017-02-03 06:09 UTC, Xia Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0884 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description Xia Zhao 2017-02-03 06:09:25 UTC
Created attachment 1247368 [details]
deployer_configmap

Description of problem:
logging stacks can't be deployed by using deployer, due to the comma seprated steps used :
$ oc get po
NAME                           READY     STATUS             RESTARTS   AGE
logging-curator-1-deploy       0/1       Error              0          21m
logging-deployer-pmq33         0/1       Completed          0          21m
logging-es-0oq2ijm2-1-deploy   0/1       Error              0          21m
logging-fluentd-s1ch9          0/1       InvalidImageName   0          21m
logging-kibana-1-deploy        0/1       Error              0          21m

$ oc get event
...
11m       21m       43        logging-kibana-1-nhp5q    Pod                                         Warning   FailedSync         {kubelet ip-172-18-15-64.ec2.internal}   Error syncing pod, skipping: [failed to "StartContainer" for "kibana" with InvalidImageName: "Failed to apply default image tag \"logging-kibana:3.5.0,IMAGE_PREFIX_DEFAULT=registry.ops.openshift.com/openshift3/\": couldn't parse image reference \"logging-kibana:3.5.0,IMAGE_PREFIX_DEFAULT=registry.ops.openshift.com/openshift3/\": invalid reference format"
, failed to "StartContainer" for "kibana-proxy" with InvalidImageName: "Failed to apply default image tag \"logging-auth-proxy:3.5.0,IMAGE_PREFIX_DEFAULT=registry.ops.openshift.com/openshift3/\": couldn't parse image reference \"logging-auth-proxy:3.5.0,IMAGE_PREFIX_DEFAULT=registry.ops.openshift.com/openshift3/\": invalid reference format"


Version-Release number of selected component (if applicable):
ops registry
openshift3/logging-deployer      3.5.0               6de669ce68d2        36 hours ago        788.6 MB

# openshift version
openshift v3.5.0.14+20b49d0
kubernetes v1.5.2+43a9be4
etcd 3.1.0

How reproducible:
Always

Steps to Reproduce:
1.Deploy logging stacks with the old way using deployer 
$ oc get configmap logging-deployer -o yaml
apiVersion: v1
data:
  enable-ops-cluster: "false"
  es-cluster-size: "1"
  es-instance-ram: 1G
  es-ops-pvc-dynamic: "false"
  es-pvc-dynamic: "false"
  journal-read-from-head: "false"
  kibana-hostname: kibana.{$subdomain}
  kibana-ops-hostname: kibana-ops.{$subdomain}
  public-master-url: https://{master-dns}:8443
  use-journal: "false"
kind: ConfigMap
metadata:
  creationTimestamp: 2017-02-03T03:22:41Z
  name: logging-deployer
  namespace: logging
  resourceVersion: "8783"
  selfLink: /api/v1/namespaces/logging/configmaps/logging-deployer
  uid: 05855e5e-e9c0-11e6-948a-0ecea5c9fb0a

$oc new-app logging-deployer-template -p IMAGE_PREFIX=registry.ops.openshift.com/openshift3/ -p IMAGE_VERSION=3.5.0 -p MODE=install

2. After deployer pod completes, check EFK pods' status
3. Check project event

Actual results:
logging stacks can't be deployed by using deployer, due to the comma seprated steps used

Expected results:
logging stacks should still be deployed by using deployer

Additional info:
deployer log attached
event attached

Comment 1 Xia Zhao 2017-02-03 06:09:49 UTC
Created attachment 1247369 [details]
deployer_log

Comment 3 Xia Zhao 2017-02-04 08:04:53 UTC
Fixed with the latest images:

ops registry:
openshift3/logging-deployer    2162a2197767
openshift3/logging-kibana    e0ab09c2cbeb
openshift3/logging-fluentd    47057624ecab
openshift3/logging-auth-proxy    139f7943475e
openshift3/logging-elasticsearch    7015704dc0f8
openshift3/logging-curator    7f034fdf7702

# openshift version
openshift v3.5.0.16+a26133a
kubernetes v1.5.2+43a9be4
etcd 3.1.0

Comment 4 Jeff Cantrill 2017-02-06 19:37:38 UTC
*** Bug 1419398 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2017-04-12 19:11:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.