Bug 1419398 - Failed in deploying logging with dynamic PV enabled
Summary: Failed in deploying logging with dynamic PV enabled
Keywords:
Status: CLOSED DUPLICATE of bug 1417261
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jeff Cantrill
QA Contact: Xia Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 03:26 UTC by Xia Zhao
Modified: 2017-02-07 06:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 19:37:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
deployer log (40.07 KB, text/plain)
2017-02-06 03:26 UTC, Xia Zhao
no flags Details
content of logging-deployer configmap (681 bytes, text/plain)
2017-02-06 03:27 UTC, Xia Zhao
no flags Details

Description Xia Zhao 2017-02-06 03:26:34 UTC
Created attachment 1247934 [details]
deployer log

Description of problem:
Deploy logging 3.5.0 stacks with dynamic PV enabled for ES and ES-ops storage, the deployer failed by comma seprated commands used for enabling dynamic PV:

$ oc logs -f logging-deployer-7wvz9
...
+ oc new-app logging-pvc-dynamic-template -p NAME=logging-es-1,SIZE=1G
warning: --param no longer accepts comma-separated lists of values. "NAME=logging-es-1,SIZE=1G" will be treated as a single key-value pair.
error: error processing template "logging/logging-pvc-dynamic-template": Template "logging-pvc-dynamic-template" is invalid: template.parameters[1]: Required value: template.parameters[1]: parameter SIZE is required and must be specified

Version-Release number of selected component (if applicable):
ops registry:
openshift3/logging-deployer    2162a2197767

# openshift version
openshift v3.5.0.16+a26133a
kubernetes v1.5.2+43a9be4
etcd 3.1.0

How reproducible:
Always

Steps to Reproduce:
1.Deploy logging 3.5.0 stacks with dynamic PV enabled in deployer configmap:
  es-ops-pvc-dynamic: "true"
  es-ops-pvc-size: 1G
  es-pvc-dynamic: "true"
  es-pvc-size: 1G

Actual results:
Deployer is in error status
--> Remove these 4 lines in deployer configmap, then redeploy logging, can be successful.

Expected results:
Deployer should complete successfully

Additional info:
full log of deployer was attached

Comment 1 Xia Zhao 2017-02-06 03:27:45 UTC
Created attachment 1247935 [details]
content of logging-deployer configmap

Comment 2 Jeff Cantrill 2017-02-06 19:37:38 UTC

*** This bug has been marked as a duplicate of bug 1418912 ***

Comment 3 Xia Zhao 2017-02-07 06:23:56 UTC
bug 1418912 was verified, and you may want to dup this with bug 1417261.

*** This bug has been marked as a duplicate of bug 1417261 ***


Note You need to log in before you can comment on or make changes to this bug.