Bug 1419245 - [abrt] setroubleshoot-server: service.py:647:_message_cb:SystemError: <built-in function isinstance> returned a result with an error set
Summary: [abrt] setroubleshoot-server: service.py:647:_message_cb:SystemError: <built-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Lautrbach
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:3d39da3bb52ff728109278f9b5c...
: 1438187 (view as bug list)
Depends On: 1366004
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-04 09:05 UTC by Dagan McGregor
Modified: 2019-02-27 01:37 UTC (History)
100 users (show)

Fixed In Version: setroubleshoot-3.3.12-3.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-28 23:54:34 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.08 KB, text/plain)
2017-02-04 09:05 UTC, Dagan McGregor
no flags Details
File: environ (88 bytes, text/plain)
2017-02-04 09:05 UTC, Dagan McGregor
no flags Details

Description Dagan McGregor 2017-02-04 09:05:00 UTC
Version-Release number of selected component:
setroubleshoot-server-3.3.11-1.fc25

Additional info:
reporter:       libreport-2.8.0
cmdline:        /usr/bin/python3 -Es /usr/sbin/setroubleshootd -f ''
executable:     /usr/sbin/setroubleshootd
kernel:         4.9.6-200.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           Python3
uid:            991

Truncated backtrace:
service.py:647:_message_cb:SystemError: <built-in function isinstance> returned a result with an error set

Traceback (most recent call last):
  File "/usr/lib64/python3.5/site-packages/dbus/connection.py", line 521, in _signal_func
    def _signal_func(self, message):
  File "/usr/lib/python3.5/site-packages/setroubleshoot/server.py", line 114, in sighandler
    sys.exit()
SystemExit

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib64/python3.5/site-packages/dbus/service.py", line 647, in _message_cb
    if not isinstance(message, MethodCallMessage):
SystemError: <built-in function isinstance> returned a result with an error set

Local variables in innermost frame:
connection: <dbus._dbus.SystemBus (system) at 0x7f0fa5749728>
message: <dbus.lowlevel.MethodCallMessage path: /org/fedoraproject/Setroubleshootd, iface: org.fedoraproject.SetroubleshootdIface, member: avc dest: org.fedoraproject.Setroubleshootd>
self: <setroubleshoot.server.SetroubleshootdDBusObject at /org/fedoraproject/Setroubleshootd at 0x7f0fa233e438>

Potential duplicate: bug 1340888

Comment 1 Dagan McGregor 2017-02-04 09:05:06 UTC
Created attachment 1247642 [details]
File: backtrace

Comment 2 Dagan McGregor 2017-02-04 09:05:07 UTC
Created attachment 1247643 [details]
File: environ

Comment 3 Damian Kostyra 2017-04-01 18:49:16 UTC
*** Bug 1438187 has been marked as a duplicate of this bug. ***

Comment 4 Steve Grubb 2017-04-04 12:42:40 UTC
This bug might be related to bug 1366004.

Comment 5 Rex Dieter 2017-04-04 13:09:46 UTC
Probably so, marking as "depends on" for now

Comment 6 robert fairbrother 2017-04-12 09:04:44 UTC
Similar problem has been detected:

possibly relaated to
https://bugzilla.redhat.com/show_bug.cgi?id=1438970
or
https://bugzilla.redhat.com/show_bug.cgi?id=1441578
https://bugzilla.redhat.com/show_bug.cgi?id=1326289

reporter:       libreport-2.8.0
cmdline:        /usr/bin/python3 -Es /usr/sbin/setroubleshootd -f ''
event_log:      2017-04-12-05:01:27> ('report_uReport' completed successfully)
executable:     /usr/sbin/setroubleshootd
kernel:         4.10.6-200.fc25.i686+PAE
package:        setroubleshoot-server-3.3.11-1.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         service.py:647:_message_cb:SystemError: <built-in function isinstance> returned a result with an error set
runlevel:       N 5
type:           Python3
uid:            987

Comment 8 Petr Lautrbach 2017-09-14 06:22:40 UTC
Testing builds are available at https://copr.fedorainfracloud.org/coprs/plautrba/setroubleshoot/

Comment 9 Fedora Update System 2017-09-15 09:52:31 UTC
setroubleshoot-3.3.12-4.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a3eb5dffa6

Comment 10 Fedora Update System 2017-09-15 10:43:31 UTC
setroubleshoot-3.3.12-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d82b89fe72

Comment 11 Fedora Update System 2017-09-15 10:59:23 UTC
setroubleshoot-3.3.12-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-be0959ff2c

Comment 12 Fedora Update System 2017-09-15 16:55:01 UTC
setroubleshoot-3.3.12-4.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a3eb5dffa6

Comment 13 Fedora Update System 2017-09-16 04:24:55 UTC
setroubleshoot-3.3.12-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d82b89fe72

Comment 14 Fedora Update System 2017-09-16 05:30:34 UTC
setroubleshoot-3.3.12-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-be0959ff2c

Comment 15 Fedora Update System 2017-09-19 07:16:39 UTC
setroubleshoot-3.3.12-5.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a3eb5dffa6

Comment 16 Fedora Update System 2017-09-19 07:19:18 UTC
setroubleshoot-3.3.12-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-be0959ff2c

Comment 17 Fedora Update System 2017-09-19 07:21:32 UTC
setroubleshoot-3.3.12-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d82b89fe72

Comment 18 Fedora Update System 2017-09-19 23:27:45 UTC
setroubleshoot-3.3.12-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a3eb5dffa6

Comment 19 Fedora Update System 2017-09-20 00:22:20 UTC
setroubleshoot-3.3.12-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d82b89fe72

Comment 20 Fedora Update System 2017-09-20 01:20:55 UTC
setroubleshoot-3.3.12-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-be0959ff2c

Comment 21 Fedora Update System 2017-09-28 19:56:19 UTC
setroubleshoot-3.3.12-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2017-09-28 23:54:34 UTC
setroubleshoot-3.3.12-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2017-09-30 06:33:38 UTC
setroubleshoot-3.3.12-5.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.