Bug 1419519 - Segfault in pam_cgroup.so
Summary: Segfault in pam_cgroup.so
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcgroup
Version: 6.9
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Nikola Forró
QA Contact: Chao Ye
URL:
Whiteboard:
: 1465918 (view as bug list)
Depends On:
Blocks: 1374441 1461138 1494124
TreeView+ depends on / blocked
 
Reported: 2017-02-06 12:01 UTC by Nikola Forró
Modified: 2021-03-11 14:56 UTC (History)
13 users (show)

Fixed In Version: libcgroup-0.40.rc1-24.el6_9
Doc Type: Bug Fix
Doc Text:
Previously, if the cgroup pluggable authentication module (PAM) was configured without arguments, the module terminated unexpectedly when opening the session. This update fixes argument processing so that such configuration is handled correctly, which prevents the described crash from occurring.
Clone Of:
: 1494124 (view as bug list)
Environment:
Last Closed: 2018-06-19 05:09:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fixed libcgroup-0.40.rc1-reading-config-files-from-etc-cgconfig.d.patch (22.42 KB, patch)
2017-02-06 12:18 UTC, Nikola Forró
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1413904 0 high VERIFIED Node is not accessible after updating libcgroup/libcgroup-pam to latest version in rhel-6.9 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2018:1861 0 None None None 2018-06-19 05:09:35 UTC

Internal Links: 1413904

Description Nikola Forró 2017-02-06 12:01:15 UTC
Description of problem:
If pam_cgroup.so is configured without arguments, it crashes while opening session.

Version-Release number of selected component (if applicable):
libcgroup-0.40.rc1-23.el6

How reproducible:
always

Steps to Reproduce:
$ yum install libcgroup libcgroup-pam openssh-server
$ service cgconfig start
$ service sshd start

# configure sshd to load pam_cgroup.so module without arguments
$ echo "session  optional  pam_cgroup.so" >> /etc/pam.d/sshd

# try to connect to localhost
$ ssh localhost

Actual results:
Write failed: Broken pipe

sshd[5849]: segfault at 0 ip 00007f2a258beac4 sp 00007ffcff89ff10 error 4 in pam_cgroup.so[7f2a258be000+1000]

Expected results:
successful login, no crash

Additional info:
Found originally in bug #1413904.

Comment 1 Nikola Forró 2017-02-06 12:18:00 UTC
Created attachment 1248024 [details]
Fixed libcgroup-0.40.rc1-reading-config-files-from-etc-cgconfig.d.patch

Comment 2 Nikola Forró 2017-02-06 12:27:06 UTC
Simple workaround is to add an agrument to pam_cgroup.so (any string will prevent the crash, but only "debug" is actually recognized):

session  optional  pam_cgroup.so  debug

Comment 3 Ion Badulescu 2017-05-22 13:47:16 UTC
The OS license might be $399 or whatever, but the fun of having to reboot a bunch of machines in single user mode to fix pam after applying this update is really priceless.

You knew about this bug more than a month before the broken libcgroup got released in 6.9, and didn't do anything about it? Didn't mark it as a blocker? STILL didn't release a fix for it, 2 months after the busted release? That's just unconscionable.

Comment 4 Nikola Forró 2017-06-28 13:17:59 UTC
*** Bug 1465918 has been marked as a duplicate of this bug. ***

Comment 5 Ondrej 2017-06-29 07:04:34 UTC
@Ion: pam_libcgroup is from the optional channel, I take it RH does not provide the same support here.

Comment 14 errata-xmlrpc 2018-06-19 05:09:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1861


Note You need to log in before you can comment on or make changes to this bug.