Bug 1465918 - pam_cgroup.so is getting segfaulted every time while trying to switch user.
pam_cgroup.so is getting segfaulted every time while trying to switch user.
Status: CLOSED DUPLICATE of bug 1419519
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcgroup (Show other bugs)
6.9
All Linux
medium Severity medium
: rc
: ---
Assigned To: Nikola Forró
Kernel General QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-28 08:44 EDT by Prasad Kulkarni
Modified: 2017-06-28 09:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 09:17:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasad Kulkarni 2017-06-28 08:44:24 EDT
Description of problem:
pam_cgroup.so is getting segfaulted every time while trying to switch user.


Version-Release number of selected component (if applicable):
libcgroup-pam.x86_64 0:0.40.rc1-23.el6 (from optional channel)

How reproducible:
Always

Steps to Reproduce:
1. Follow the steps mentioned under "Procedure 4.4. Using a PAM module to move processes to cgroups" section in https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Resource_Management_Guide/sec-cpu_and_memory-use_case.html to install and configure pam-libcgroup module

2. use "su" command to become a different user on a system.

3. You will receive "segmentation fault" message and following will be logged in messages file.

-------
Jun 27 16:10:36 rhel6u9-3 yum[1954]: Installed: libcgroup-pam-0.40.rc1-23.el6.x86_64
Jun 27 16:17:30 rhel6u9-3 kernel: su[2090]: segfault at 0 ip 00007f030fcd6ac4 sp 00007ffe99d1c940 error 4 in pam_cgroup.so[7f030fcd6000+1000]
Jun 27 16:17:31 rhel6u9-3 abrt[2091]: Saved core dump of pid 2090 (/bin/su) to /var/spool/abrt/ccpp-2017-06-27-16:17:31-2090 (3239936 bytes)
Jun 27 16:17:31 rhel6u9-3 abrtd: Directory 'ccpp-2017-06-27-16:17:31-2090' creation detected
Jun 27 16:17:41 rhel6u9-3 kernel: ip_tables: (C) 2000-2006 Netfilter Core Team
-------

Actual results:
While switching to any (normal) user receive "segmentation fault" message.

Expected results:
Switch user should work.
Comment 4 Nikola Forró 2017-06-28 09:17:59 EDT
Hi Prasad,

this bug has already been reported, although with sshd service.

*** This bug has been marked as a duplicate of bug 1419519 ***

Note You need to log in before you can comment on or make changes to this bug.