Bug 1419559 - Installation of certmonger fails with nothing provides libxmlrpc_util.so.3()(64bit) needed by certmonger-0.78.6-4.fc26.x86_64
Summary: Installation of certmonger fails with nothing provides libxmlrpc_util.so.3()(...
Keywords:
Status: CLOSED DUPLICATE of bug 1405790
Alias: None
Product: Fedora
Classification: Fedora
Component: certmonger
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 13:52 UTC by Jan Pazdziora
Modified: 2017-02-10 21:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-10 21:59:28 UTC


Attachments (Terms of Use)

Description Jan Pazdziora 2017-02-06 13:52:10 UTC
Description of problem:

Attempt to install certmonger fails with

Error: conflicting requests
  - nothing provides libxmlrpc_util.so.3()(64bit) needed by certmonger-0.78.6-4.fc26.x86_64

Version-Release number of selected component (if applicable):

certmonger-0.78.6-4.fc26.x86_64

How reproducible:

Deterministic.

Steps to Reproduce:
1. docker run --rm -ti fedora:rawhide dnf install certmonger

Actual results:

$ docker run --rm -ti fedora:rawhide dnf install certmonger
rawhide                                          60 MB/s |  52 MB     00:00    
Last metadata expiration check: 0:00:24 ago on Mon Feb 06 13:50:49 2017 UTC.
Error: conflicting requests
  - nothing provides libxmlrpc_util.so.3()(64bit) needed by certmonger-0.78.6-4.fc26.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages)

Expected results:

No dependency error.

Additional info:

This blocks FreeIPA testing on Fedora rawhide.

Comment 1 Lukas Slebodnik 2017-02-10 21:59:28 UTC
certmonger need to be rebuilt with new version of xmlrpc_c
however compilation failed because certmonger cannot be compiled with openssl-1.1. it need to be ported to openssl-1.1

*** This bug has been marked as a duplicate of bug 1405790 ***


Note You need to log in before you can comment on or make changes to this bug.