Bug 1419606 - ISS import need clarification
Summary: ISS import need clarification
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Docs Content Management Guide
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: Sergei Petrosian
QA Contact: Russell Dickenson
URL:
Whiteboard:
: 1302601 (view as bug list)
Depends On:
Blocks: 1455785 1459128
TreeView+ depends on / blocked
 
Reported: 2017-02-06 15:15 UTC by David Juran
Modified: 2019-10-10 12:15 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1459128 (view as bug list)
Environment:
Last Closed: 2017-07-04 11:57:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description David Juran 2017-02-06 15:15:30 UTC
Document URL: 
https://access.redhat.com/documentation/en/red-hat-satellite/6.2/single/content-management-guide/#importing_a_content_view_as_a_red_hat_repository



Describe the issue: 

Once a content view has been exported, it's far from clear at what level in the hierarchy one should point the CDN URL at in step 6.
The secret is, to point it to the directory containing a directory name "content"
In my case, that worked out to http://upstream_sat/pub/export/Default_Organization-Red_Hat_Enterprise_Linux_7-v9.0/Default_Organization/content_views/Red_Hat_Enterprise_Linux_7/9.0/



Additional information: 
Also, step 1 and 2 is confusing. Why not just stating that the exported data need to be made available over http?

Further, it would be worth clarifying that a repository also can be imported as a custom repo, in a custom product

Comment 2 Andrew Dahms 2017-02-08 23:30:31 UTC
Assigning to Charles for review.

Charles - it looks like there might be two main parts to this bug.

1. Clarifying the level in the hierarchy the CDN URL should be in Step 6., 
   changing Step 1. and Step 2. so that they state that content need be 
   made available over HTTP (remove Step 1.?), and add a note that a
   repository can also be imported as a custom repo in a custom product.

2. Adding an appendix to the CMG that pulls in some of the information from
   the blog post called out to provide a reference to how the CDN is 
   organized.

Comment 13 Andrew Dahms 2017-05-29 06:22:14 UTC
Re-assigning to Sergei for review.

Sergei - this is a bug that has already been worked on a little, so there is an existing branch and some early content that we can use as the basis for closing out this request.

This request is for a feature called inter-Satellite-sync, which allows you to copy content from one Satellite environment to another.

In the bug, we have been requested to provide some more detail about how this works. Specifically, what the 'URL' should be when pointing to the Satellite environment instead of the Customer Portal, and an overview of how content directories are structured.

What we need to do is incorporate the recommendations from comment #7 as follows -

* Check that the duplicate content has been removed.

* Check the UI and see if there are any further steps in the procedure.

* Move the content on the structure of the CDN to the Architecture Guide.
  It is fairly broad conceptual information, so perhaps as a new chapter
  under the current Chapter 3.? Let's also add a link to this from the section
  in the Content Management Guide added via this bug.

When these changes have been made, raise a needinfo request here in Bugzilla against the reporter - David Juran - to see if the added content provides sufficient clarification.

Let me know if you have any questions!

Comment 14 Andrew Dahms 2017-05-29 06:27:03 UTC
*** Bug 1302601 has been marked as a duplicate of this bug. ***

Comment 24 Stephen Wadeley 2017-06-27 12:49:32 UTC
I raised:

Bug 1465444 - Exporting Content View Versions needs clarification

Comment 29 Sergei Petrosian 2017-07-03 11:43:21 UTC
These changes are now live on the customer portal.


Thank you


Note You need to log in before you can comment on or make changes to this bug.