Bug 1419721 - Remove red error message from gutterball/ES on upgrades
Summary: Remove red error message from gutterball/ES on upgrades
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Upgrades
Version: 6.2.7
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Chris Roberts
QA Contact: Lukas Pramuk
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: 1426419
TreeView+ depends on / blocked
 
Reported: 2017-02-06 21:21 UTC by Chris Roberts
Modified: 2019-09-26 14:48 UTC (History)
7 users (show)

Fixed In Version: katello-installer-base-3.0.0.79-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1426419 (view as bug list)
Environment:
Last Closed: 2017-05-01 13:59:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 18307 None None None 2017-02-12 08:01:18 UTC
Red Hat Product Errata RHBA-2017:1191 normal SHIPPED_LIVE Satellite 6.2.9 Async Bug Release 2017-05-01 17:49:42 UTC

Description Chris Roberts 2017-02-06 21:21:43 UTC
Description of problem:
Upgrading along 6.2.Z stream should not run remove_gutterball and elasticsearch_message. These steps are relevant to upgrading from 6.1

Hit when upgraded between GA snaps and elasticsearch_message and remove_gutterball steps were run needlessly. And assuming that touches 6.2.zstream

Version-Release number of selected component (if applicable):
satellite-6.2.0-20.1.el7sat.noarch

How reproducible:
always

Steps to Reproduce:
1. # yum upgrade # but not from sat6.1
2. # satellite-installer -S satellite --upgrade
...
Upgrade Step: elasticsearch_message...
package elasticsearch is not installed
...
Upgrade Step: remove_gutterball...
package gutterball is not installed
...


Actual results:
not appropriate upgrade steps are run needlessly.

Expected results:
only relevant steps are run when upgrading along 6.2.zstream

Comment 2 pm-sat@redhat.com 2017-02-23 21:11:45 UTC
Please add verifications steps for this bug to help QE verify

Comment 4 Lukas Pramuk 2017-03-28 10:08:12 UTC
VERIFIED.

@satellite-6.2.9-1.0.el7sat.noarch
katello-installer-base-3.0.0.79-1.el7sat.noarch

1. Upgrade 6.2.8 > 6.2.9
# satellite-installer --upgrade
...

Upgrade Step: elasticsearch_message...
Upgrade Step: add_export_distributor (this may take a while) ...
...

Upgrade Step: remove_gutterball...
Upgrade Step: remove_event_queue...
...

2. Upgrade 6.1.11 > 6.2.9
# satellite-installer --upgrade
...

Upgrade Step: elasticsearch_message...
Elasticsearch has been removed as a dependency.  The database files can be removed manually with # rm -rf /var/lib/elasticsearch.  Some packages are no longer needed and can be removed:  # yum erase ruby193-rubygem-tire tfm-rubygem-tire elasticsearch sigar-java sigar snappy-java lucene4-contrib lucene4
Upgrade Step: add_export_distributor (this may take a while) ...
...

Upgrade Step: remove_gutterball...
No Match for argument: tfm-rubygem-foreman_gutterball
No Match for argument: tfm-rubygem-hammer_cli_gutterball

================================================================================
 Package        Arch   Version          Repository                         Size
================================================================================
Removing:
 gutterball     noarch 1.0.15.0.2-1.el7 @rhel-7-server-satellite-6.1-rpms 301 k
 gutterball-certs
                noarch 1.0-1            installed                          11 k

Transaction Summary
================================================================================
Remove  2 Packages

Installed size: 312 k
warning: /etc/gutterball/gutterball.conf saved as /etc/gutterball/gutterball.conf.rpmsave

Removed:
  gutterball.noarch 0:1.0.15.0.2-1.el7      gutterball-certs.noarch 0:1.0-1     


removed directory: ‘/var/lib/tomcat/webapps/gutterball’

Upgrade Step: remove_event_queue...
...

>>> when the steps are not applicable (1.) the error msgs were removed
>>> while when the steps are applicable (2.) they are performed as before

Comment 6 errata-xmlrpc 2017-05-01 13:59:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1191


Note You need to log in before you can comment on or make changes to this bug.