Bug 1419749 - [RFE] Composable Minor Updates [for RHOSP12] (Ansible based, in composable fashion) (Ansible based, hybrid environment support)
Summary: [RFE] Composable Minor Updates [for RHOSP12] (Ansible based, in composable fa...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: Upstream M3
: 12.0 (Pike)
Assignee: mathieu bultel
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
: 1391705 1419748 (view as bug list)
Depends On: 1447127
Blocks: 1442136 1415556
TreeView+ depends on / blocked
 
Reported: 2017-02-06 23:32 UTC by Jaromir Coufal
Modified: 2018-02-01 17:04 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-01 17:04:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1715557 None None None 2017-09-28 11:37:09 UTC
OpenStack gerrit 487488 'None' 'MERGED' 'Implement minor update workflow with config download' 2019-11-16 12:02:52 UTC
OpenStack gerrit 487496 'None' 'MERGED' 'Execute minor update via ansible on mistral' 2019-11-16 12:02:53 UTC
OpenStack gerrit 510408 'None' 'MERGED' 'Adds pacemaker update_tasks for Pike minor update workflow' 2019-11-16 12:02:52 UTC

Description Jaromir Coufal 2017-02-06 23:32:26 UTC
Re-use work which was done for composable upgrades and adapt same procedure for updates in order to isolate errors and minimize amount of duplication in procedures.

Comment 3 Jaromir Coufal 2017-03-13 05:10:43 UTC
*** Bug 1391705 has been marked as a duplicate of this bug. ***

Comment 6 Steven Hardy 2017-04-26 16:22:00 UTC
Note I am already working on patches to enable this for the docker based architecture - it's probably possible to adjust the eventual (ansible based) model there to also handle updates on the host, but I've not looked at that yet.

It's not really as simple as reusing tasks from composable upgrades though, as all those really do is stop services, and packaging already restarts them for us in most cases.

IMHO having a parallel effort to rework the current yum_update.sh model into ansible probably isn't worthwhile so we'll need to work together, as I think we'll need upgrades integrated with the container deployment (just updating things on the host is no longer enough, we have to restart containers with the services in, vs have packaging handle restarts as is the case today).

WIP patches here:

https://review.openstack.org/#/c/454816/
https://review.openstack.org/#/c/456254/
https://review.openstack.org/#/c/456307/
https://review.openstack.org/#/c/456308
https://review.openstack.org/#/c/456309/
https://review.openstack.org/#/c/456310/
https://review.openstack.org/#/c/456311
https://review.openstack.org/#/c/459390/

The end goal is to have a playbook we can run end-to-end (all steps) on each node in a rolling fashion, and depending on how we run it it may be possible to enable operators to run it one step at a time.

Comment 7 Sofer Athlan-Guyot 2017-05-31 12:03:39 UTC
https://review.openstack.org/#/c/462211
https://review.openstack.org/#/c/467581

and keeping yum_update.sh for non-containerized.

Comment 8 Jaromir Coufal 2017-06-12 19:50:45 UTC
*** Bug 1419748 has been marked as a duplicate of this bug. ***

Comment 12 Amit Ugol 2017-12-13 09:32:10 UTC
100% test execution, no blockers or serious issues with this feature.


Note You need to log in before you can comment on or make changes to this bug.