Bug 1419839 - [IntService_public_295] even openshift_metrics_heapster_standalone=true, metrics and cassandra is deployed
Summary: [IntService_public_295] even openshift_metrics_heapster_standalone=true, metr...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Hawkular
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.5.z
Assignee: John Sanda
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1421011
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 08:40 UTC by Peng Li
Modified: 2018-10-03 20:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-03 20:41:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Peng Li 2017-02-07 08:40:23 UTC
Description of problem:
In the inventory file, set openshift_metrics_heapster_standalone=True, this should only deploy heapseter, but Cassandra and Hawkular Metrics is installed.

Version-Release number of selected component (if applicable):
OCP 3.5

How reproducible:
always

Steps to Reproduce:
1.prepare inventory file

[oo_first_master]
$MASTER ansible_user=root ansible_ssh_user=root ansible_ssh_private_key_file="/root/.ssh/libra.pem" openshift_public_hostname=$MASTER

[oo_first_master:vars]
deployment_type=openshift-enterprise
openshift_release=v3.5.0

openshift_metrics_install_metrics=true

openshift_metrics_hawkular_hostname=hawkular-metrics.$SUBDOMAIN
openshift_metrics_project=openshift-infra


openshift_metrics_image_prefix=registry.ops.openshift.com/openshift3/
openshift_metrics_image_version=3.5.0

openshift_metrics_heapster_standalone=True

2.# ansible-playbook  -vvv  -i  ~/inventory  playbooks/common/openshift-cluster/openshift_metrics.yml

Actual results:
#oc get pod -n openshift-infra
NAME                         READY     STATUS    RESTARTS   AGE
hawkular-cassandra-1-lfh47   1/1       Running   0          11m
hawkular-metrics-t54ws       1/1       Running   0          11m
heapster-s89dv               1/1       Running   0          11m


Expected results:
Should only deploy heapster

Additional info:
Ansible log is attached.

Comment 2 Jeff Cantrill 2017-02-08 00:59:10 UTC
fixed in: https://github.com/openshift/openshift-ansible/pull/3284

Comment 3 Jeff Cantrill 2017-02-08 16:28:21 UTC
Lowering the priority since this is only known to be required in origin.

Comment 6 Matt Wringe 2017-09-29 18:54:33 UTC
is this still an issue? I would like to get this closed if its no longer a problem.

Comment 7 Junqi Zhao 2017-09-30 04:02:19 UTC
It is not a problem now, tested with openshift-ansible-3.5.128-1, only heaspter pod is deployed when setting openshift_metrics_heapster_standalone=True

Please close this defect.

Comment 8 Junqi Zhao 2017-09-30 05:09:24 UTC
Set it to VERIFIED based on Comment 7


Note You need to log in before you can comment on or make changes to this bug.