Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1421011 - ruamel.yaml package installation failed when enable metrics or logging deployment
Summary: ruamel.yaml package installation failed when enable metrics or logging deploy...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Jan Chaloupka
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On: 1422638
Blocks: 1419839 1419874
TreeView+ depends on / blocked
 
Reported: 2017-02-10 06:01 UTC by Gaoyun Pei
Modified: 2017-07-24 14:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-13 12:02:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0903 0 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix and enhancement 2017-04-12 22:45:42 UTC

Description Gaoyun Pei 2017-02-10 06:01:57 UTC
Description of problem:
When enable metrics or logging deployment during installation, installer will fail at "TASK [lib_openshift : lib_openshift ensure python-ruamel-yaml package is on target".


Version-Release number of selected component (if applicable):
openshift-ansible-3.5.6-1.git.0.5e6099d.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Set openshift_hosted_metrics_deploy=true or openshift_hosted_logging_deploy=true in ansible inventory, trigger installation.


Actual results:
TASK [lib_openshift : lib_openshift ensure python-ruamel-yaml package is on target] ***
Friday 10 February 2017  03:11:10 +0000 (0:00:00.789)       0:34:04.324 ******* 
failed: [ec2-54-196-128-51.compute-1.amazonaws.com] (item=[u'ruamel.yaml', u'ruamel.yaml', u'ruamel.yaml', u'ruamel.yaml', u'ruamel.yaml', u'ruamel.yaml']) => {
    "changed": false, 
    "failed": true, 
    "item": [
        "ruamel.yaml", 
        "ruamel.yaml", 
        "ruamel.yaml", 
        "ruamel.yaml", 
        "ruamel.yaml", 
        "ruamel.yaml"
    ], 
    "rc": 126, 
    "results": [
        "No package matching 'ruamel.yaml' found available, installed or updated"
    ]
}

MSG:

No package matching 'ruamel.yaml' found available, installed or updated



Expected results:


Additional info:

Comment 1 Xia Zhao 2017-02-10 06:31:04 UTC
Blocks logging & metrics deployment by executing ansible scripts.

Comment 2 Jan Chaloupka 2017-02-10 13:54:39 UTC
Upstream PR https://github.com/openshift/openshift-ansible/pull/3327

Comment 3 Jan Chaloupka 2017-02-10 14:19:37 UTC
Merged in openshift-ansible.

Gaoyun Pei, can you verify?

Comment 5 Gaoyun Pei 2017-02-12 02:16:00 UTC
Hi Jan,

Tried with openshift-ansible-3.5.7-1.git.0.5010dec.el7.noarch.rpm, it's working well for rpm installation on RHEL, but for containerized installation on Atomic Host, we don't have 'yum' command on it, so it would still get failed.

TASK [lib_openshift : lib_openshift ensure python-ruamel-yaml package is on target] ***
Saturday 11 February 2017  16:31:53 +0000 (0:00:00.122)       0:34:10.295 ***** 
fatal: [ec2-54-242-217-249.compute-1.amazonaws.com]: FAILED! => {
    "changed": false, 
    "failed": true
}

MSG:

Could not find a module for unknown.

Since it's not a blocker for rpm installation, so remove the TestBlocker keyword.

Comment 6 Scott Dodson 2017-02-17 02:16:40 UTC
back to on_qa the atomic host environment should be fixed now.

Comment 7 Gaoyun Pei 2017-02-17 09:58:24 UTC
Tried setting openshift_hosted_metrics_deploy=true or openshift_hosted_logging_deploy=true in ansible inventory, trigger installation on Atomic Host, installer would skip python-ruamel-yaml package install step now, and the installation is successful, move this bug to verified.

Comment 8 Gaoyun Pei 2017-02-17 10:02:46 UTC
Fixed in version openshift-ansible-3.5.10-1.git.0.ba66b63.el7.noarch


Note You need to log in before you can comment on or make changes to this bug.