Bug 1419846 - removing warning related to enum, to let the build take place without errors for 3.10
Summary: removing warning related to enum, to let the build take place without errors ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.10
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
Assignee: hari gowtham
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1418973
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 08:49 UTC by hari gowtham
Modified: 2017-03-06 17:45 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1418973
Environment:
Last Closed: 2017-03-06 17:45:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description hari gowtham 2017-02-07 08:49:42 UTC
+++ This bug was initially created as a clone of Bug #1418973 +++

Description of problem:

The usage of two different enums checked under one enum in the function glusterd_remove_brick_validate_bricks might cause serious issues when the function uses various cases.

How reproducible:
no change in the current functionality. 
Build will throw errors. 

Steps to Reproduce:
1.with the source code trying to make it
2.will throw warnings
3.will fail if we try to build packages.

Actual results:
build failure with error

Expected results:
To build without error and work in future without breaking.

Additional info:

--- Additional comment from Worker Ant on 2017-02-03 05:33:07 EST ---

REVIEW: https://review.gluster.org/16539 (Tier: remove warning related to the enum) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-02-03 06:08:20 EST ---

REVIEW: https://review.gluster.org/16539 (Tier: remove warning related to the enum) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-02-06 02:10:09 EST ---

REVIEW: https://review.gluster.org/16539 (Tier: remove warning related to the enum) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-02-06 06:27:46 EST ---

REVIEW: https://review.gluster.org/16539 (Tier: remove warning related to the enum) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)

--- Additional comment from Worker Ant on 2017-02-07 00:12:33 EST ---

COMMIT: https://review.gluster.org/16539 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit f2133923b8d8851943c5676b88c5ce67725eabe5
Author: hari gowtham <hgowtham@redhat.com>
Date:   Fri Feb 3 15:55:47 2017 +0530

    Tier: remove warning related to the enum
    
    PROBLEM: In the tier as a service patch the enums for tier (from
    gf1_op_command and gf_defrag_command) are put into a single enum
    gf_defrag_command which causes a warning that will make the build
    fail.
    
    FIX: send both the enum and eliminate the warning.
    
    Change-Id: I899ff622dfb07134e6459aa65f65ea7252765293
    BUG: 1418973
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: https://review.gluster.org/16539
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 1 Worker Ant 2017-02-07 09:32:37 UTC
REVIEW: https://review.gluster.org/16553 (Tier: remove warning related to the enum) posted (#1) for review on release-3.10 by hari gowtham (hari.gowtham005@gmail.com)

Comment 2 Worker Ant 2017-02-08 14:16:08 UTC
COMMIT: https://review.gluster.org/16553 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit e576a061c394dea5a665ea8a6185831fe13d4af7
Author: hari gowtham <hgowtham@redhat.com>
Date:   Fri Feb 3 15:55:47 2017 +0530

    Tier: remove warning related to the enum
    
            back-port of : https://review.gluster.org/#/c/16539/
    
    PROBLEM: In the tier as a service patch the enums for tier (from
    gf1_op_command and gf_defrag_command) are put into a single enum
    gf_defrag_command which causes a warning that will make the build
    fail.
    
    FIX: send both the enum and eliminate the warning.
    
    >Change-Id: I899ff622dfb07134e6459aa65f65ea7252765293
    >BUG: 1418973
    >Signed-off-by: hari gowtham <hgowtham@redhat.com>
    >Reviewed-on: https://review.gluster.org/16539
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: I8d2ec89b8689066091ab58406d225e1058f435cf
    BUG: 1419846
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: https://review.gluster.org/16553
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: hari gowtham <hari.gowtham005@gmail.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 3 Shyamsundar 2017-03-06 17:45:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.