Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1419874 - Metrics deployment failed during installation
Summary: Metrics deployment failed during installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: ewolinet
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On: 1421011
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 10:04 UTC by Gaoyun Pei
Modified: 2017-07-24 14:11 UTC (History)
5 users (show)

Fixed In Version: openshift-ansible-3.5.8-1.git.0.0e02ef8.el7
Doc Type: No Doc Update
Doc Text:
This was a QE opened bz due to updating the metrics role
Clone Of:
Environment:
Last Closed: 2017-04-12 18:49:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1454929 0 unspecified CLOSED [DOCS] openshift_metrics_hawkular_hostname is no longer required 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2017:0903 0 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix and enhancement 2017-04-12 22:45:42 UTC

Internal Links: 1454929

Description Gaoyun Pei 2017-02-07 10:04:26 UTC
Description of problem:
Enable metrics deployment during installation with setting openshift_hosted_metrics_deploy=true, installation playbook failed as

TASK [openshift_metrics : Check that hawkular_metrics_hostname is set] *********
Tuesday 07 February 2017  09:22:39 +0000 (0:00:00.268)       0:15:16.403 ****** 
fatal: [ec2-54-152-80-115.compute-1.amazonaws.com]: FAILED! => {"changed": false, "failed": true, "msg": "the openshift_metrics_hawkular_hostname variable is required"}


Seems like a new option openshift_metrics_hawkular_hostname is required for metrics deployment, but it wasn't introduced in https://github.com/openshift/openshift-ansible/blob/master/inventory/byo/hosts.ose.example


Version-Release number of selected component (if applicable):
openshift-ansible-3.5.4-1.git.0.034b615.el7.noarch.rpm
ansible-2.2.1.0-2.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1.Set openshift_hosted_metrics_deploy=true in ansible inventory, run the installation playbook

Actual results:


Expected results:


Additional info:

Comment 3 Gaoyun Pei 2017-02-12 02:19:13 UTC
Test this issue with openshift-ansible-3.5.7-1.git.0.5010dec.el7.noarch.rpm.

Still got the same error.

TASK [openshift_metrics : Check that hawkular_metrics_hostname is set] *********
Saturday 11 February 2017  16:19:16 +0000 (0:00:00.199)       0:20:33.710 ***** 
fatal: [ec2-52-70-65-86.compute-1.amazonaws.com]: FAILED! => {
    "changed": false, 
    "failed": true
}

MSG:

the openshift_metrics_hawkular_hostname variable is required

Comment 5 Gaoyun Pei 2017-02-15 04:41:48 UTC
Test this bug with openshift-ansible-3.5.8-1.git.0.0e02ef8.el7.noarch.rpm, it could work well on rpm env, will verify whether it works on containerized env after BZ#1421011 fixed.

For rpm installed ocp-3.5 env, set openshift_hosted_metrics_deploy=true in ansible inventory file, installation could be finished, and metrics related pod are all running.

[root@ip-172-18-12-122 ~]# oc get pod -n openshift-infra
NAME                         READY     STATUS    RESTARTS   AGE
hawkular-cassandra-1-19hhq   1/1       Running   0          4m
hawkular-metrics-bm95r       1/1       Running   0          4m
heapster-bqr6s               1/1       Running   0          4m

Comment 6 Gaoyun Pei 2017-02-17 10:03:03 UTC
AS BZ#1421011 has been fixed, metrics basic deployment could be done via installer now, verify with openshift-ansible-3.5.10-1.git.0.ba66b63.el7.noarch

Comment 8 errata-xmlrpc 2017-04-12 18:49:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0903


Note You need to log in before you can comment on or make changes to this bug.