Bug 1419889 - [RFE][Swift] Standalone Swift deployments with TripleO
Summary: [RFE][Swift] Standalone Swift deployments with TripleO
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: Upstream M2
: 12.0 (Pike)
Assignee: Thiago da Silva
QA Contact: Mike Abrams
URL:
Whiteboard:
: 1320209 (view as bug list)
Depends On:
Blocks: 1442136 1471619
TreeView+ depends on / blocked
 
Reported: 2017-02-07 10:34 UTC by Christian Schwede (cschwede)
Modified: 2018-02-05 19:04 UTC (History)
13 users (show)

Fixed In Version: openstack-tripleo-heat-templates-7.0.0-0.20170624014919.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1471619 (view as bug list)
Environment:
Last Closed: 2017-12-13 21:08:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
Example roles_data.yaml Swift/Keystone only overcloud (2.37 KB, text/plain)
2017-06-15 13:30 UTC, Christian Schwede (cschwede)
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 456864 None MERGED Support for external swift proxy 2020-03-24 09:45:26 UTC
OpenStack gerrit 456871 None MERGED Support for external swift proxy 2020-03-24 09:45:27 UTC
OpenStack gerrit 474571 None MERGED Update external Swift configuration doc 2020-03-24 09:45:28 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Internal Links: 1453058

Description Christian Schwede (cschwede) 2017-02-07 10:34:10 UTC
Part 1: as an operator, I'd like to be able to deploy a Swift cluster using TripleO.

This should include only the following services/nodes:

- Keystone
- MariaDB/Galera for Keystone
- Loadbalancers (haproxy)
- Swift proxy nodes
- Swift storage nodes

This can be done already using composable roles, but needs QE verification and documentation.

--------------------

Part 2: as an operator with an already existing Swift (deployed manually, self-automated or by using TripleO) cluster I'd like to re-use it with a new TripleO deployment. This means:

Swift services need to be disabled in TripleO, but at the same time endpoints need to be defined and configured appropriately to use the external Swift cluster.

Comment 2 Christian Schwede (cschwede) 2017-03-23 12:29:49 UTC
*** Bug 1320209 has been marked as a duplicate of this bug. ***

Comment 3 Christian Schwede (cschwede) 2017-04-25 19:55:17 UTC
Part 2 of this RFE has been merged upstream a few days ago:

https://review.openstack.org/#/c/456871/
https://review.openstack.org/#/c/456864/

Moving to POST. Still needs documentation.

Comment 7 Christian Schwede (cschwede) 2017-06-15 13:15:08 UTC
Proposed a doc update for the external Swift cluster: https://review.openstack.org/#/c/474571/

Some notes on testing an external Swift cluster: https://gist.github.com/cschwede/7474fd44a5a3e51526e881e51e28576e

Comment 8 Christian Schwede (cschwede) 2017-06-15 13:30:42 UTC
Created attachment 1288063 [details]
Example roles_data.yaml Swift/Keystone only overcloud

Comment 19 errata-xmlrpc 2017-12-13 21:08:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.