Bug 1419893 - [quick installer]quick installer failed due to a non-existent file_name
Summary: [quick installer]quick installer failed due to a non-existent file_name
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Wenkai Shi
URL:
Whiteboard:
Depends On:
Blocks: 1439109 1440588 1440614
TreeView+ depends on / blocked
 
Reported: 2017-02-07 10:52 UTC by Wenkai Shi
Modified: 2017-07-24 14:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1439109 1440588 1440614 (view as bug list)
Environment:
Last Closed: 2017-03-08 14:06:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0903 0 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix and enhancement 2017-04-12 22:45:42 UTC

Description Wenkai Shi 2017-02-07 10:52:21 UTC
Description of problem:
quick installer failed due to a nonexistent file_name.

Version-Release number of selected component (if applicable):
atomic-openshift-utils-3.5.4-1.git.0.034b615

How reproducible:
100%

Steps to Reproduce:
1.prepare a host for quick installer
2.atomic-openshift-installer install
3.

Actual results:
[root@openshift ~]# atomic-openshift-installer install
...
Gathering information from hosts...
ERROR! the file_name '/usr/share/ansible/openshift-ansible/common/openshift-cluster/std_include.yml' does not exist, or is not readable
There was a problem fetching the required information. Please see /tmp/ansible.log for details.

Expected results:
Installation succeed

Additional info:
[root@openshift ~]# ll /usr/share/ansible/openshift-ansible/common/openshift-cluster/std_include.yml
ls: cannot access /usr/share/ansible/openshift-ansible/common/openshift-cluster/std_include.yml: No such file or directory

[root@openshift ~]# ll /usr/share/ansible/openshift-ansible/playbooks/common/openshift-cluster/std_include.yml
-rw-r--r--. 1 root root 870 Feb  6 20:11 /usr/share/ansible/openshift-ansible/playbooks/common/openshift-cluster/std_include.yml

[root@openshift ~]# grep "include" /usr/share/ansible/openshift-ansible/playbooks/byo/openshift_facts.yml
- include: ../../common/openshift-cluster/std_include.yml

Comment 2 openshift-github-bot 2017-02-07 15:27:53 UTC
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/118d223181520f1e8f11619ab1a6a9ff3fcae9b5
Fix playbooks/byo/openshift_facts.yml include path

Fixes Bug 1419893

Comment 4 Scott Dodson 2017-02-08 02:46:03 UTC
This is fixed in 3.5.5 which is building a puddle right now.

Comment 5 Wenkai Shi 2017-02-08 09:18:37 UTC
Verified with version atomic-openshift-utils-3.5.5-1.git.0.3ae2138.el7, the path is correct now.

[root@openshift ~]# grep "include" /usr/share/ansible/openshift-ansible/playbooks/byo/openshift_facts.yml
- include: ../common/openshift-cluster/std_include.yml


Note You need to log in before you can comment on or make changes to this bug.