Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1419922 - Query instance details for <sat server> task failed with the following error: Fog::Compute::Vsphere::NotFound
Summary: Query instance details for <sat server> task failed with the following error:...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.2.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 12:17 UTC by Waldirio M Pinheiro
Modified: 2020-03-11 15:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-09 16:26:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 11690 0 Normal Rejected Since Upgrade to 1.9 host creating through API post fails with Fog::Compute::Vsphere::NotFound 2021-01-11 11:47:30 UTC

Description Waldirio M Pinheiro 2017-02-07 12:17:02 UTC
Description of problem:
When customer try to provision one new content host, receive the error according below

*Query instance details for <satellite hostname> task failed with the following error: Fog::Compute::Vsphere::NotFound*

Version-Release number of selected component (if applicable):
satellite-6.2.6-2.0.el7sat.noarch

How reproducible:
100% on the customer environment

Steps to Reproduce:
1. Create new Content Host
2. Define all parameters
3. Submit

Actual results:
Error message according below

*
Unable to save
Query instance details for <satellite hostname> task failed with the following error: Fog::Compute::Vsphere::NotFound
*

Expected results:
Create the content host

Additional info:

Comment 5 Ivan Necas 2017-02-07 15:37:02 UTC
I would like to ask for output of this script:

cat <<EOF | foreman-rake console
require 'pp'
Foreman::Model::Vmware.all.each do |cr|
  service = cr.send(:client); ""
  pp cr.attributes.except('password')
  raw_networks = service.list_networks(:datacenter => cr.datacenter)
  pp raw_networks
end;""
EOF

This will print information about the compute resources and the available networks.

Comment 13 Ivan Necas 2017-02-08 21:30:20 UTC
After analylizing the provided source and additional data, it seems the issue was in applying wrong patch to address https://bugzilla.redhat.com/show_bug.cgi?id=1394290: it seems the patch 'vsphere-unique-networks.patch' was applied, which was later in the original BZ as commented in https://bugzilla.redhat.com/show_bug.cgi?id=1394290#c40, where also the right patch is provided. To fix the issue, I suggest first reverting the original patch and then applying the new one:

  cd /usr/share/foreman
  # revert the original patch
  patch -Rp1 < ~/vsphere-unique-networks.patch
  # apply new patch
  patch -p1 < ~/vsphere-dvportgroup-key.patch
  service httpd restart

After doing this, it might be needed to re-save the compute profile used while using the previous patch, but should help with the original issue.

In case this doesn't help, please share latest sosreports and fresh tar of `/usr/share/foreman` to see the state of sources after reversing the old patch and applying the new one

Comment 17 Ivan Necas 2017-02-09 16:26:25 UTC
Since this issue was caused by applying wrong patch to resolve https://bugzilla.redhat.com/show_bug.cgi?id=1394290, I'm closing this BZ as NOTABUG


Note You need to log in before you can comment on or make changes to this bug.