Bug 141998 - symbol lookup error: /usr/lib/libgnomevfs-2.so.0: undefined symbol: xmlNewTextReaderFilename
symbol lookup error: /usr/lib/libgnomevfs-2.so.0: undefined symbol: xmlNewTex...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libxml2 (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-06 12:13 EST by Michal Lijowski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-06 12:24:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/xses-michal.ADRqWc (4.03 KB, text/plain)
2004-12-06 12:15 EST, Michal Lijowski
no flags Details

  None (edit)
Description Michal Lijowski 2004-12-06 12:13:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
While I login I get the message
There was an error starting the GNOME Settings Daemon.
Some things, such as themes, sounds, or background settings may not
work correctly.
The Settings Daemon restarted too many times.
The last error message was:
Child process did not give an error message, unknown failure occurred
GNOME will still try to restart the Settings Daemon next time you log in.

I have attached /tmp/xses-michal.ADRqWc which contain messages 
like 
Warning: program compiled against libxml 206 using older 204.

I submitted this as a bug Bug 160370: Gnome Settings Daemon failure
in http://bugzilla.gnome.org/show_bug.cgi?id=160370 and the response
was 

This is a distribution problem. See "Warning: program compiled against
libxml
206 using older 204"
You need to update the libxml2 package.

The libxml2 are the most recent

[michal@ml-cvu ~]$ rpm -qa | grep libxml2
libxml2-python-2.6.16-3
libxml2-2.6.16-3
libxml2-devel-2.6.16-3

The only solution to this problem is to back up user's directory,
delete user/recreate user, and restore data. But after a few 
logouts/logins I get the above message on the desktop and the 
warnigs in /tmp/xses file. This problem occurs in my default user
account. I was not able to reproduce it in other accounts which I 
own on the same machine.

When I try to invoke 

[michal@ml-cvu ~]$ gedit
gedit: symbol lookup error: /usr/lib/libgtksourceview-1.0.so.0:
undefined symbol: xmlNewTextReaderFilename

This problem seems to be related to FC3. I did not have it 
in the previous versions starting from RH Linux 9 and upgrading
to FC1, and FC2. 




Version-Release number of selected component (if applicable):
libxml2-2.6.16-3

How reproducible:
Always

Steps to Reproduce:
1. Create new user
2. Login 
3. Logout

  Repetitively, login/logout, reboot 
    

Actual Results:  [michal@ml-cvu ~]$ evolution
evolution: symbol lookup error: /usr/lib/libgnomevfs-2.so.0: undefined
symbol: xmlNewTextReaderFilename
[michal@ml-cvu ~]$ gedit
gedit: symbol lookup error: /usr/lib/libgtksourceview-1.0.so.0:
undefined symbol: xmlNewTextReaderFilename


Expected Results:  I should not have to have above errors.

Additional info:

Linux ml-cvu.wustl.edu 2.6.9-1.681_FC3 #1 Thu Nov 18 15:10:10 EST 2004
i686 i686 i386 GNU/Linux
Comment 1 Michal Lijowski 2004-12-06 12:15:24 EST
Created attachment 107968 [details]
/tmp/xses-michal.ADRqWc
Comment 2 Daniel Veillard 2004-12-06 12:24:49 EST
Seems relatively clear to me that you have an old libxml2-2.4.x
shared library laying around in your LD_LIBRARY_PATH and taking
predecedence over the system 2.6.16 library. 
Use "ldd evolution" to find out what libxml2.so.2 is is using and fix
this. 
This does not look like a fedora bug, but IMHO and user or system
setting error. If ldd indicates that the libxml2 shared library 
used comes from a Fedora core package, please reopen the bug
indicating what package provided the libxml2.so.2 library generating
the problem.

Daniel
Comment 3 Michal Lijowski 2004-12-06 13:44:04 EST
Thank you, Daniel.

I have ActiveTcl and ldd /usr/bin/evolution gives
libxml2.so.2 => /usr/local/ActiveTcl/lib/libxml2.so.2 (0x00a43000)

Michal
Comment 4 Daniel Veillard 2004-12-06 18:08:32 EST
Okidoc, I think it's the second time the ActiveTcl generated some
mess, I should alk to them, but over the mailing-list at gnome.org.
You should also open a bug on their side to track this down, in the
meantime I think this one can be safely closed.

  thanks for the feedback,

Daniel

Note You need to log in before you can comment on or make changes to this bug.