Bug 1420012 - perl-IO-Compress-2.070-1.fc26 FTBS: tests fail with zlib ≥ 1.2.9
Summary: perl-IO-Compress-2.070-1.fc26 FTBS: tests fail with zlib ≥ 1.2.9
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-IO-Compress
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
Depends On:
Blocks: 1420326
TreeView+ depends on / blocked
 
Reported: 2017-02-07 15:34 UTC by Petr Pisar
Modified: 2017-02-10 10:26 UTC (History)
3 users (show)

Fixed In Version: perl-IO-Compress-2.070-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-10 10:26:02 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CPAN 120134 0 None None None 2017-02-07 15:34:51 UTC

Description Petr Pisar 2017-02-07 15:34:52 UTC
perl-IO-Compress-2.070-1.fc26 fails to build in F26 because some tests fail:

t/999pod.t ...................... ok
#     Failed test (t/cz-01version.t at line 34)
#          got: '1.2.8'
#     expected: '1.2.11'
# 
# The version of zlib.h does not match the version of libz
#  
# You have zlib.h version 1.2.8
# 	 and libz   version 1.2.11
#  
# You probably have two versions of zlib installed on your system.
# Try removing the one you don't want to use and rebuild.
# Looks like you failed 1 test of 3.
t/cz-01version.t ................ 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/3 subtests 
#     Failed test (t/cz-03zlib-v1.t at line 53)
#          got: '1.2.11'
#     expected: '1.2.8'
#     Failed test (t/cz-03zlib-v1.t at line 742)
#     Failed test (t/cz-03zlib-v1.t at line 754)
#     Failed test (t/cz-03zlib-v1.t at line 766)
#     Failed test (t/cz-03zlib-v1.t at line 788)
#     Failed test (t/cz-03zlib-v1.t at line 790)
# Looks like you failed 6 tests of 472.
t/cz-03zlib-v1.t ................ 
Dubious, test returned 6 (wstat 1536, 0x600)
Failed 6/472 subtests 
t/cz-05examples.t ............... ok
#     Failed test (t/cz-06gzsetp.t at line 48)
#          got: '1.2.11'
#     expected: '1.2.8'
#     Failed test (t/cz-06gzsetp.t at line 75)
#          got: -1
#     expected: 0
#     Failed test (t/cz-06gzsetp.t at line 90)
#          got: '74154'
#     expected: '-1'
#     Failed test (t/cz-06gzsetp.t at line 92)
#     Failed test (t/cz-06gzsetp.t at line 93)
#     Failed test (t/cz-06gzsetp.t at line 125)
#     Failed test (t/cz-06gzsetp.t at line 137)
#          got: '-1'
#     expected: '74154'
# Inflation Error: data error
#     Failed test (t/cz-06gzsetp.t at line 140)
# unc len = , input len = 74154
#     Failed test (t/cz-06gzsetp.t at line 143)
#     Failed test (t/cz-06gzsetp.t at line 125)
#     Failed test (t/cz-06gzsetp.t at line 137)
#          got: '-1'
#     expected: '74154'
# Inflation Error: data error
#     Failed test (t/cz-06gzsetp.t at line 140)
# unc len = , input len = 74154
#     Failed test (t/cz-06gzsetp.t at line 143)
#     Failed test (t/cz-06gzsetp.t at line 125)
#     Failed test (t/cz-06gzsetp.t at line 137)
#          got: '247'
#     expected: '74154'
# Inflation Error: data error
#     Failed test (t/cz-06gzsetp.t at line 140)
# unc len = 247, input len = 74154
#     Failed test (/usr/share/perl5/vendor_perl/Test/NoWarnings.pm at line 45)
# There were 5 warning(s)
# 	Previous test 11 ''
# 	Use of uninitialized value $uncompressed in string eq at t/cz-06gzsetp.t line 92.
#  at t/cz-06gzsetp.t line 92.
# 
# ----------
# 	Previous test 23 ''
# 	Use of uninitialized value $uncompressed in string eq at t/cz-06gzsetp.t line 140.
#  at t/cz-06gzsetp.t line 140.
# 
# ----------
# 	Previous test 24 'got expected uncompressed data'
# 	Use of uninitialized value $uncompressed in concatenation (.) or string at t/cz-06gzsetp.t line 140.
#  at t/cz-06gzsetp.t line 140.
# 
# ----------
# 	Previous test 35 ''
# 	Use of uninitialized value $uncompressed in string eq at t/cz-06gzsetp.t line 140.
#  at t/cz-06gzsetp.t line 140.
# 
# ----------
# 	Previous test 36 'got expected uncompressed data'
# 	Use of uninitialized value $uncompressed in concatenation (.) or string at t/cz-06gzsetp.t line 140.
#  at t/cz-06gzsetp.t line 140.
# 
# Looks like you failed 17 tests of 52.
t/cz-06gzsetp.t ................. 
Dubious, test returned 17 (wstat 4352, 0x1100)
Failed 17/52 subtests 
#     Failed test (t/cz-08encoding.t at line 43)
#          got: '1.2.11'
#     expected: '1.2.8'
# Looks like you failed 1 test of 30.
t/cz-08encoding.t ............... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/30 subtests 
#     Failed test (t/cz-14gzopen.t at line 34)
#          got: '1.2.11'
#     expected: '1.2.8'
# Looks like you failed 1 test of 265.
t/cz-14gzopen.t ................. 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/265 subtests 
t/globmapper.t .................. ok
Test Summary Report
-------------------
t/cz-01version.t              (Wstat: 256 Tests: 3 Failed: 1)
  Failed test:  2
  Non-zero exit status: 1
t/cz-03zlib-v1.t              (Wstat: 1536 Tests: 472 Failed: 6)
  Failed tests:  4, 208, 212, 216, 224-225
  Non-zero exit status: 6
t/cz-06gzsetp.t               (Wstat: 4352 Tests: 52 Failed: 17)
  Failed tests:  1, 6, 11-13, 19, 23-25, 31, 35-37, 43, 47-48
                52
  Non-zero exit status: 17
t/cz-08encoding.t             (Wstat: 256 Tests: 30 Failed: 1)
  Failed test:  2
  Non-zero exit status: 1
t/cz-14gzopen.t               (Wstat: 256 Tests: 265 Failed: 1)
  Failed test:  3
  Non-zero exit status: 1
Files=87, Tests=72204, 2033 wallclock secs ( 4.62 usr  0.39 sys + 2002.82 cusr  2.13 csys = 2009.96 CPU)
Result: FAIL

This is caused by upgrading zlib from 1.2.8 to 1.2.9.

The version tests need rebuilding perl-Compress-Raw-Zlib (done in 2.071-2.fc26).

Some t/cz-03zlib-v1.t tests need the same fix as I applied to perl-Compress-Raw-Zlib (CPAN RT#119762).

Comment 1 Petr Pisar 2017-02-10 08:32:22 UTC
I will adjust the tests. After fixing perl-Compress-Raw-Zlib properly, the patch will be removed.


Note You need to log in before you can comment on or make changes to this bug.