Bug 1420326 - perl-5.24.1-387.fc26 FTBFS: tests fail with zlib ≥ 1.2.9
Summary: perl-5.24.1-387.fc26 FTBFS: tests fail with zlib ≥ 1.2.9
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://apps.fedoraproject.org/kosche...
Whiteboard:
Depends On: 1419841 1420012
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 13:08 UTC by Petr Pisar
Modified: 2017-02-10 12:16 UTC (History)
9 users (show)

Fixed In Version: perl-5.24.1-388.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-10 12:16:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Pisar 2017-02-08 13:08:53 UTC
perl-5.24.1-387.fc26 fails to build in F26 because tests fail:

Test Summary Report
-------------------
../cpan/Compress-Raw-Zlib/t/02zlib.t                            (Wstat: 1280 Tests: 317 Failed: 5)
  Failed tests:  148, 152, 156, 164-165
  Non-zero exit status: 5
../cpan/IO-Compress/t/cz-03zlib-v1.t                            (Wstat: 1280 Tests: 471 Failed: 5)
  Failed tests:  208, 212, 216, 224-225
  Non-zero exit status: 5
../cpan/IO-Compress/t/cz-06gzsetp.t                             (Wstat: 3840 Tests: 51 Failed: 15)
  Failed tests:  6, 11-13, 19, 23-25, 31, 35-37, 43, 47-48
  Non-zero exit status: 15
Files=2412, Tests=861992, 442 wallclock secs (173.62 usr 10.37 sys + 983.15 cusr 48.74 csys = 1215.88 CPU)
Result: FAIL

This is caused by upgrading zlib from 1.2.8 to 1.2.9. Fixes for bundled IO-Compress and Compress-Raw-Zlib must be ported.

Comment 1 Petr Pisar 2017-02-10 08:57:27 UTC
I will adjust the tests. After fixing perl-Compress-Raw-Zlib properly, the patch will be removed.


Note You need to log in before you can comment on or make changes to this bug.