Bug 1420050 - db error when I open bug #1 at beta-bugzilla.redhat.com
Summary: db error when I open bug #1 at beta-bugzilla.redhat.com
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Bugzilla
Classification: Community
Component: Database
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
: 1420356 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 16:38 UTC by Jan Stavel
Modified: 2017-02-08 21:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-07 23:56:46 UTC


Attachments (Terms of Use)

Description Jan Stavel 2017-02-07 16:38:50 UTC
Description of problem:

Openning a bug either
by https://beta-bugzilla.redhat.com/show_bug.cgi?id=1
or https://beta-bugzilla.redhat.com/rest/bug/1&api_key=XXXXXXXXXXX

gives an error:

Version-Release number of selected component (if applicable):


How reproducible:

everytime.

Steps to Reproduce:
- log in https://beta-bugzilla.redhat.com
- open bug #1 https://beta-bugzilla.redhat.com/show_bug.cgi?id=1

Actual results:

You see an error page:

An error occurred while performing a database operation:

DBD::Pg::db selectall_hashref failed: ERROR:  relation "attach_data" does not exist
LINE 2: ...                       FROM attachments LEFT JOIN attach_dat...
                                                             ^ [for Statement "SELECT attach_id, LENGTH(thedata) AS datasize
                                   FROM attachments LEFT JOIN attach_data ON attach_id = id
                                   WHERE bug_id = ?"]
<pre>
 at /var/www/html/bugzilla/Bugzilla/Attachment.pm line 699.
	Bugzilla::Attachment::get_attachments_by_bug('Bugzilla::Attachment', 'Bugzilla::Bug=HASH(0x7f43657211f8)', 'HASH(0x7f4361bebeb8)') called at /var/www/html/bugzilla/Bugzilla/Bug.pm line 4097
	Bugzilla::Bug::attachments('Bugzilla::Bug=HASH(0x7f43657211f8)') called at /var/www/html/bugzilla/extensions/InlineHistory/Extension.pm line 58
	Bugzilla::Extension::InlineHistory::template_before_process('Bugzilla::Extension::InlineHistory=HASH(0x7f4364abb160)', 'HASH(0x7f436563bc60)') called at /var/www/html/bugzilla/Bugzilla/Hook.pm line 21
	Bugzilla::Hook::process('template_before_process', 'HASH(0x7f436563bc60)') called at /var/www/html/bugzilla/Bugzilla/Template/Context.pm line 76
	Bugzilla::Template::Context::stash('Bugzilla::Template::Context=HASH(0x7f4361341f90)') called at /var/www/html/bugzilla/data/template//var/www/html/bugzilla/template/en/default/bug/edit.html.tmpl line 14
	Template::Provider::__ANON__('Bugzilla::Template::Context=HASH(0x7f4361341f90)') called at /usr/lib64/perl5/vendor_perl/Template/Document.pm line 163
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Document.pm line 161
	Template::Document::process('Template::Document=HASH(0x7f436588ea10)', 'Bugzilla::Template::Context=HASH(0x7f4361341f90)') called at /usr/lib64/perl5/vendor_perl/Template/Context.pm line 351
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Context.pm line 321
	Template::Context::process('Bugzilla::Template::Context=HASH(0x7f4361341f90)', 'bug/edit.html.tmpl') called at /var/www/html/bugzilla/Bugzilla/Template/Context.pm line 35
	Bugzilla::Template::Context::process('Bugzilla::Template::Context=HASH(0x7f4361341f90)', 'bug/edit.html.tmpl') called at /var/www/html/bugzilla/template/en/default/bug/show.html.tmpl line 29
	eval {...} called at /var/www/html/bugzilla/template/en/default/bug/show.html.tmpl line 18
	Template::Provider::__ANON__('Bugzilla::Template::Context=HASH(0x7f4361341f90)') called at /usr/lib64/perl5/vendor_perl/Template/Document.pm line 163
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Document.pm line 161
	Template::Document::process('Template::Document=HASH(0x7f4364ad8d78)', 'Bugzilla::Template::Context=HASH(0x7f4361341f90)') called at /usr/lib64/perl5/vendor_perl/Template/Context.pm line 351
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Context.pm line 321
	Template::Context::process('Bugzilla::Template::Context=HASH(0x7f4361341f90)', 'Template::Document=HASH(0x7f4364ad8d78)') called at /var/www/html/bugzilla/Bugzilla/Template/Context.pm line 35
	Bugzilla::Template::Context::process('Bugzilla::Template::Context=HASH(0x7f4361341f90)', 'Template::Document=HASH(0x7f4364ad8d78)') called at /usr/lib64/perl5/vendor_perl/Template/Service.pm line 94
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Service.pm line 91
	Template::Service::process('Template::Service=HASH(0x7f4364d4fa08)', 'bug/show.html.tmpl', 'HASH(0x7f4364ab7400)') called at /usr/lib64/perl5/vendor_perl/Template.pm line 66
	Template::process('Bugzilla::Template=HASH(0x7f4364aa9480)', 'bug/show.html.tmpl', 'HASH(0x7f4364ab7400)') called at /var/www/html/bugzilla/Bugzilla/Template.pm line 721
	Bugzilla::Template::process('Bugzilla::Template=HASH(0x7f4364aa9480)', 'bug/show.html.tmpl', 'HASH(0x7f4364ab7400)') called at /var/www/html/bugzilla/show_bug.cgi line 142
	ModPerl::ROOT::Bugzilla::ModPerl::ResponseHandler::var_www_html_bugzilla_show_bug_2ecgi::handler('Apache2::RequestRec=SCALAR(0x7f4364aa8ee0)') called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 207
	eval {...} called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 207
	ModPerl::RegistryCooker::run('Bugzilla::ModPerl::ResponseHandler=HASH(0x7f4364959768)') called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 173
	ModPerl::RegistryCooker::default_handler('Bugzilla::ModPerl::ResponseHandler=HASH(0x7f4364959768)') called at /usr/lib64/perl5/vendor_perl/ModPerl/Registry.pm line 32
	ModPerl::Registry::handler('Bugzilla::ModPerl::ResponseHandler', 'Apache2::RequestRec=SCALAR(0x7f4364aa8ee0)') called at /var/www/html/bugzilla/mod_perl.pl line 141
	Bugzilla::ModPerl::ResponseHandler::handler('Bugzilla::ModPerl::ResponseHandler', 'Apache2::RequestRec=SCALAR(0x7f4364aa8ee0)') called at -e line 0
	eval {...} called at -e line 0

</pre>

Comment 1 Jeff Fearn 🐞 2017-02-07 23:56:46 UTC
Hi, this was  configuration issue, resolved  via RT.

Comment 2 Jeff Fearn 🐞 2017-02-08 21:33:45 UTC
*** Bug 1420356 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.