Bug 1420356 - stack trace accessing a bug
Summary: stack trace accessing a bug
Keywords:
Status: CLOSED DUPLICATE of bug 1420050
Alias: None
Product: Bugzilla
Classification: Community
Component: WebService
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 14:11 UTC by Scott Poore
Modified: 2017-02-20 15:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-08 21:33:45 UTC


Attachments (Terms of Use)

Description Scott Poore 2017-02-08 14:11:45 UTC
Description of problem:

When I try to access a specific bug in bugzilla from the web interface, I see a failure and traceback.  See full text below.

Version-Release number of selected component (if applicable):
5.0

How reproducible:
unknown.  not occurring now.

Steps to Reproduce:
1.  Log into beta bugzilla instance
2.  search for bug #1192099
3.

Actual results:

failure below

Expected results:

retrieve bug info.


Additional info:

This is the failure output I saw last night:

Note: This is a test instance of Bugzilla.

An unexpected error occurred. This could be a temporary problem, or some code is behaving incorrectly. If this problem persists, please email this page to bugzilla-requests@redhat.com with details of what you were doing at the time this message appeared.

URL: https://beta-bugzilla.redhat.com/show_bug.cgi?id=1192099
An error occurred while performing a database operation:

DBD::Pg::db selectall_hashref failed: ERROR:  relation "attach_data" does not exist
LINE 2: ...                       FROM attachments LEFT JOIN attach_dat...
                                                             ^ [for Statement "SELECT attach_id, LENGTH(thedata) AS datasize
                                   FROM attachments LEFT JOIN attach_data ON attach_id = id
                                   WHERE bug_id = ?"]
<pre>
 at /var/www/html/bugzilla/Bugzilla/Attachment.pm line 699.
	Bugzilla::Attachment::get_attachments_by_bug('Bugzilla::Attachment', 'Bugzilla::Bug=HASH(0x7f4364dc65d0)', 'HASH(0x7f4361bebeb8)') called at /var/www/html/bugzilla/Bugzilla/Bug.pm line 4097
	Bugzilla::Bug::attachments('Bugzilla::Bug=HASH(0x7f4364dc65d0)') called at /var/www/html/bugzilla/extensions/InlineHistory/Extension.pm line 58
	Bugzilla::Extension::InlineHistory::template_before_process('Bugzilla::Extension::InlineHistory=HASH(0x7f4364dc9d20)', 'HASH(0x7f43653602e0)') called at /var/www/html/bugzilla/Bugzilla/Hook.pm line 21
	Bugzilla::Hook::process('template_before_process', 'HASH(0x7f43653602e0)') called at /var/www/html/bugzilla/Bugzilla/Template/Context.pm line 76
	Bugzilla::Template::Context::stash('Bugzilla::Template::Context=HASH(0x7f436501ec08)') called at /var/www/html/bugzilla/data/template//var/www/html/bugzilla/template/en/default/bug/edit.html.tmpl line 14
	Template::Provider::__ANON__('Bugzilla::Template::Context=HASH(0x7f436501ec08)') called at /usr/lib64/perl5/vendor_perl/Template/Document.pm line 163
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Document.pm line 161
	Template::Document::process('Template::Document=HASH(0x7f4365327110)', 'Bugzilla::Template::Context=HASH(0x7f436501ec08)') called at /usr/lib64/perl5/vendor_perl/Template/Context.pm line 351
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Context.pm line 321
	Template::Context::process('Bugzilla::Template::Context=HASH(0x7f436501ec08)', 'bug/edit.html.tmpl') called at /var/www/html/bugzilla/Bugzilla/Template/Context.pm line 35
	Bugzilla::Template::Context::process('Bugzilla::Template::Context=HASH(0x7f436501ec08)', 'bug/edit.html.tmpl') called at /var/www/html/bugzilla/template/en/default/bug/show.html.tmpl line 29
	eval {...} called at /var/www/html/bugzilla/template/en/default/bug/show.html.tmpl line 18
	Template::Provider::__ANON__('Bugzilla::Template::Context=HASH(0x7f436501ec08)') called at /usr/lib64/perl5/vendor_perl/Template/Document.pm line 163
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Document.pm line 161
	Template::Document::process('Template::Document=HASH(0x7f436505a5c8)', 'Bugzilla::Template::Context=HASH(0x7f436501ec08)') called at /usr/lib64/perl5/vendor_perl/Template/Context.pm line 351
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Context.pm line 321
	Template::Context::process('Bugzilla::Template::Context=HASH(0x7f436501ec08)', 'Template::Document=HASH(0x7f436505a5c8)') called at /var/www/html/bugzilla/Bugzilla/Template/Context.pm line 35
	Bugzilla::Template::Context::process('Bugzilla::Template::Context=HASH(0x7f436501ec08)', 'Template::Document=HASH(0x7f436505a5c8)') called at /usr/lib64/perl5/vendor_perl/Template/Service.pm line 94
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Service.pm line 91
	Template::Service::process('Template::Service=HASH(0x7f436501f058)', 'bug/show.html.tmpl', 'HASH(0x7f436506ba68)') called at /usr/lib64/perl5/vendor_perl/Template.pm line 66
	Template::process('Bugzilla::Template=HASH(0x7f4364dc9f30)', 'bug/show.html.tmpl', 'HASH(0x7f436506ba68)') called at /var/www/html/bugzilla/Bugzilla/Template.pm line 721
	Bugzilla::Template::process('Bugzilla::Template=HASH(0x7f4364dc9f30)', 'bug/show.html.tmpl', 'HASH(0x7f436506ba68)') called at /var/www/html/bugzilla/show_bug.cgi line 142
	ModPerl::ROOT::Bugzilla::ModPerl::ResponseHandler::var_www_html_bugzilla_show_bug_2ecgi::handler('Apache2::RequestRec=SCALAR(0x7f4364ade908)') called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 207
	eval {...} called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 207
	ModPerl::RegistryCooker::run('Bugzilla::ModPerl::ResponseHandler=HASH(0x7f43651bb850)') called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 173
	ModPerl::RegistryCooker::default_handler('Bugzilla::ModPerl::ResponseHandler=HASH(0x7f43651bb850)') called at /usr/lib64/perl5/vendor_perl/ModPerl/Registry.pm line 32
	ModPerl::Registry::handler('Bugzilla::ModPerl::ResponseHandler', 'Apache2::RequestRec=SCALAR(0x7f4364ade908)') called at /var/www/html/bugzilla/mod_perl.pl line 141
	Bugzilla::ModPerl::ResponseHandler::handler('Bugzilla::ModPerl::ResponseHandler', 'Apache2::RequestRec=SCALAR(0x7f4364ade908)') called at -e line 0
	eval {...} called at -e line 0

</pre>

Traceback:

 at /var/www/html/bugzilla/Bugzilla/DB.pm line 191.
	Bugzilla::DB::_handle_error(...) called at /var/www/html/bugzilla/Bugzilla/Attachment.pm line 699
	Bugzilla::Attachment::get_attachments_by_bug(...) called at /var/www/html/bugzilla/Bugzilla/Bug.pm line 4097
	Bugzilla::Bug::attachments(...) called at /var/www/html/bugzilla/extensions/InlineHistory/Extension.pm line 58
	Bugzilla::Extension::InlineHistory::template_before_process(...) called at /var/www/html/bugzilla/Bugzilla/Hook.pm line 21
	Bugzilla::Hook::process(...) called at /var/www/html/bugzilla/Bugzilla/Template/Context.pm line 76
	Bugzilla::Template::Context::stash(...) called at /var/www/html/bugzilla/data/template//var/www/html/bugzilla/template/en/default/bug/edit.html.tmpl line 14
	Template::Provider::__ANON__(...) called at /usr/lib64/perl5/vendor_perl/Template/Document.pm line 163
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Document.pm line 161
	Template::Document::process(...) called at /usr/lib64/perl5/vendor_perl/Template/Context.pm line 351
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Context.pm line 321
	Template::Context::process(...) called at /var/www/html/bugzilla/Bugzilla/Template/Context.pm line 35
	Bugzilla::Template::Context::process(...) called at /var/www/html/bugzilla/template/en/default/bug/show.html.tmpl line 29
	eval {...} called at /var/www/html/bugzilla/template/en/default/bug/show.html.tmpl line 18
	Template::Provider::__ANON__(...) called at /usr/lib64/perl5/vendor_perl/Template/Document.pm line 163
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Document.pm line 161
	Template::Document::process(...) called at /usr/lib64/perl5/vendor_perl/Template/Context.pm line 351
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Context.pm line 321
	Template::Context::process(...) called at /var/www/html/bugzilla/Bugzilla/Template/Context.pm line 35
	Bugzilla::Template::Context::process(...) called at /usr/lib64/perl5/vendor_perl/Template/Service.pm line 94
	eval {...} called at /usr/lib64/perl5/vendor_perl/Template/Service.pm line 91
	Template::Service::process(...) called at /usr/lib64/perl5/vendor_perl/Template.pm line 66
	Template::process(...) called at /var/www/html/bugzilla/Bugzilla/Template.pm line 721
	Bugzilla::Template::process(...) called at /var/www/html/bugzilla/show_bug.cgi line 142
	ModPerl::ROOT::Bugzilla::ModPerl::ResponseHandler::var_www_html_bugzilla_show_bug_2ecgi::handler(...) called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 207
	eval {...} called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 207
	ModPerl::RegistryCooker::run(...) called at /usr/lib64/perl5/vendor_perl/ModPerl/RegistryCooker.pm line 173
	ModPerl::RegistryCooker::default_handler(...) called at /usr/lib64/perl5/vendor_perl/ModPerl/Registry.pm line 32
	ModPerl::Registry::handler(...) called at /var/www/html/bugzilla/mod_perl.pl line 141
	Bugzilla::ModPerl::ResponseHandler::handler(...) called at -e line 0
	eval {...} called at -e line 0

Comment 1 Jeff Fearn 🐞 2017-02-08 21:33:45 UTC
Search works for me, looks like a dupe of 1420050. Please let me know if you are still seeing this though.

*** This bug has been marked as a duplicate of bug 1420050 ***

Comment 2 Scott Poore 2017-02-20 15:25:17 UTC
No, I only saw it once.  If I see it again, I'll reopen the bug.

Thanks,
Scott


Note You need to log in before you can comment on or make changes to this bug.