Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1420095 - Installation guide lists an unsupported undercloud.conf option, clean_nodes
Summary: Installation guide lists an unsupported undercloud.conf option, clean_nodes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Dan Macpherson
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-07 19:28 UTC by David Critch
Modified: 2017-04-19 15:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-08 18:03:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description David Critch 2017-02-07 19:28:43 UTC
Description of problem:
In the OSP10 director install guide (https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/paged/director-installation-and-usage/chapter-4-installing-the-undercloud) the clean_nodes option is mentioned for undercloud.conf. However automatic node cleaning is not currently supported in OSP10 and is planned for OSP11.

Version-Release number of selected component (if applicable):
instack-undercloud-5.2.0-1.el7ost.noarch

How reproducible:
Always

Steps to Reproduce:
1. Follow OSP10 director installation
2. Set clean_nodes to true in undercloud.conf
3. Install undercloud

Actual results:
undercloud install fails to properly setup automatic ironic node cleaning. Attempting to deploy an overcloud fails when the cleaning ultimately fails and times out.

Expected results:
The option should be removed from the docs until it is supported in OSP11

Additional info:
I tried some manual steps to get it work with little success, but ultimately was told this is planned for OSP11. See https://bugzilla.redhat.com/show_bug.cgi?id=1398657

Comment 2 Dan Macpherson 2017-02-08 02:16:29 UTC
Hi David,

The clean_nodes parameter has been removed:

https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/single/director-installation-and-usage/#sect-Configuring_the_Director

Was there anything else required for this BZ?

Comment 3 David Critch 2017-02-08 15:59:52 UTC
Hi Dan,

That's perfect, thanks! I've heard from a couple of customers who tried to enable it and were a little bit disappointed.

I think that will do it for this BZ. While submitting this one, I did notice that it is also listed in the example undercloud.conf w/ ship with the instack-undercloud package. Could this BZ cover getting that fixed up, or should I open a new one?

Comment 4 Dan Macpherson 2017-02-08 18:03:40 UTC
Hi David,

Re: undercloud.conf, you might need to create a new BZ since it's a different component from documentation.

Comment 5 Jim Bagwell 2017-04-19 15:47:10 UTC
Hello, while the option has been removed in the RHOSP10 install documentation, the option still exists within the undercloud.conf. These two files should be aligned as not to confuse the user.


Note You need to log in before you can comment on or make changes to this bug.