Bug 1420294 - Leftover /opt/rh/rh-nodejs6/root/usr/share/licenses after uninstallation
Summary: Leftover /opt/rh/rh-nodejs6/root/usr/share/licenses after uninstallation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-nodejs6
Version: rh-nodejs6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: beta
: 2.3
Assignee: Zuzana Svetlikova
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On: 1316626
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 11:37 UTC by Miroslav Hradílek
Modified: 2017-04-26 10:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1316626
Environment:
Last Closed: 2017-04-26 10:13:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1145 normal SHIPPED_LIVE new packages: rh-nodejs6 2017-04-26 13:48:12 UTC

Description Miroslav Hradílek 2017-02-08 11:37:51 UTC
Cloning this bug as the problem is present on rh-nodejs6 and still appears with  rh-nodejs4 too even though the filesystem bug is verified.

Unreleased: rh-nodejs6-runtime-2.4-4.el7.x86_64

+++ This bug was initially created as a clone of Bug #1316626 +++

Description of problem:

There is: /opt/rh/rh-nodejs4/root/usr/share/licenses leftover after collection uninstallation due to not being owned by any package.

Version-Release number of selected component (if applicable):
rh-nodejs4-2.2-5.el7.x86_64 (unreleased)


::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: rh-nodejs4
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: Using package list
:: [   FAIL   ] :: All files in /opt/rh/rh-nodejs4 owned by that collection 
:: [   LOG    ] :: Files in the question:
:: [   LOG    ] :: /opt/rh/rh-nodejs4/root/usr/share/licenses
:: [   LOG    ] :: Duration: 11s
:: [   LOG    ] :: Assertions: 0 good, 1 bad
:: [   FAIL   ] :: RESULT: rh-nodejs4

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Destructive part
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: Using package list
:: [   FAIL   ] :: No files left after the yum remove 
:: [   LOG    ] :: /opt/rh/rh-nodejs4/root/usr/share/licenses
:: [   LOG    ] :: Duration: 5m 4s
:: [   LOG    ] :: Assertions: 0 good, 1 bad
:: [   FAIL   ] :: RESULT: Destructive part

--- Additional comment from Zuzana Svetlikova on 2016-04-21 10:07:57 EDT ---

This bug is caused by filesystem not owning the directory, not bug in scl package.

https://bugzilla.redhat.com/show_bug.cgi?id=1278300

--- Additional comment from Miroslav Hradílek on 2016-04-21 12:31:30 EDT ---

Does this explanation count for collections and therefor /opt/rh/rh-nodejs4 prefixed path?

--- Additional comment from Zuzana Svetlikova on 2016-06-14 02:27:11 EDT ---

Yes.

Comment 4 errata-xmlrpc 2017-04-26 10:13:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1145


Note You need to log in before you can comment on or make changes to this bug.