Bug 1420463 - Unable to import json file to create nodes in openstack
Summary: Unable to import json file to create nodes in openstack
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-openstackclient
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: ---
: ---
Assignee: Julie Pichon
QA Contact: Shai Revivo
URL:
Whiteboard:
: 1420464 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 17:56 UTC by Vijay Murugesan
Modified: 2020-08-13 08:51 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-25 12:29:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vijay Murugesan 2017-02-08 17:56:24 UTC
Description of problem:
While trying the import the json file using openstack import command it fails with the following error message:
publicURL endpoint for workflowv2 service not found

Version-Release number of selected component (if applicable):
Platform 10

How reproducible:


Steps to Reproduce:
1. Install undercloud using openstack undercloud install
2. Add DNS nameserver to the subnet using the following:neutron subnet-update b39a68fd-c24b-426b-923f-d9b7c0aa0d2d --dns-nameservers list=true 172.20.0.235
3. Create a new instackenv.json with the following contents
{
    "nodes":[
        {
            "cpu":"4",
            "memory":"6144",
            "disk":"40",
            "arch":"x86_64",
            "pm_type":"pxe_ipmitool",
            "pm_user":"admin",
            "pm_password":"p@55w0rd!",
            "pm_addr":"192.0.2.205"
        }
    ]
}
4. Run the following command to import the json to create the node
openstack baremetal import --json ~/instackenv.json

Actual results:
publicURL endpoint for workflowv2 service not found

Expected results:
Node shoud be created.

Additional info:

Comment 1 Mike Burns 2017-02-09 12:32:49 UTC
*** Bug 1420464 has been marked as a duplicate of this bug. ***

Comment 2 Balihar Singh 2017-03-21 14:49:19 UTC
Hi 

Is there any workaround  ?

Comment 3 Derek Higgins 2017-04-07 15:07:47 UTC
Hi Vijay,

   I haven't been able to reproduce this, can you take a look in 

/home/<user>/.instack/install-undercloud.log
for sign of any errors(look for the string workflowv2)

also if you run the command "openstack endpoint list" is there an entry for mistral or workflowv2?

Comment 7 Dmitry Tantsur 2017-10-25 12:29:48 UTC
Hi!

Are you using ironic in the overcloud? The "baremetal import" command is a part of TripleO, it won't work there. Please follow the official documentation or use its upstream equivalent: http://tripleo.org/install/advanced_deployment/baremetal_overcloud.html#enrolling-nodes

If you mean the undercloud, we cannot reproduce the bug without information requested in comment 3.


Note You need to log in before you can comment on or make changes to this bug.