Bug 1420464 - Unable to import json file to create nodes in openstack
Summary: Unable to import json file to create nodes in openstack
Keywords:
Status: CLOSED DUPLICATE of bug 1420463
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-utils
Version: 9.0 (Mitaka)
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Lon Hohberger
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-08 18:01 UTC by Vijay Murugesan
Modified: 2017-02-09 12:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-09 12:32:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vijay Murugesan 2017-02-08 18:01:12 UTC
Description of problem:
While trying the import the json file using openstack import command it fails with the following error message:
publicURL endpoint for workflowv2 service not found

Version-Release number of selected component (if applicable):
Platform 10

How reproducible:


Steps to Reproduce:
1. Install undercloud using openstack undercloud install
2. Add DNS nameserver to the subnet using the following:neutron subnet-update b39a68fd-c24b-426b-923f-d9b7c0aa0d2d --dns-nameservers list=true 172.20.0.235
3. Create a new instackenv.json with the following contents
{
    "nodes":[
        {
            "cpu":"4",
            "memory":"6144",
            "disk":"40",
            "arch":"x86_64",
            "pm_type":"pxe_ipmitool",
            "pm_user":"admin",
            "pm_password":"p@55w0rd!",
            "pm_addr":"192.0.2.205"
        }
    ]
}
4. Run the following command to import the json to create the node
openstack baremetal import --json ~/instackenv.json

Actual results:
publicURL endpoint for workflowv2 service not found

Expected results:
Node shoud be created.

Additional info:

Comment 1 Mike Burns 2017-02-09 12:32:49 UTC

*** This bug has been marked as a duplicate of bug 1420463 ***


Note You need to log in before you can comment on or make changes to this bug.