RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1420574 - Trying to access a non-existent directory using automount results in 4 minute hang as not checking the local mount availability [rhel-7]
Summary: Trying to access a non-existent directory using automount results in 4 minute...
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: autofs
Version: 7.3
Hardware: All
OS: Linux
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: Yongcheng Yang
Milan Navratil
Depends On: 1396403
TreeView+ depends on / blocked
Reported: 2017-02-09 01:02 UTC by Ian Kent
Modified: 2017-08-01 12:43 UTC (History)
11 users (show)

Fixed In Version: autofs-5.0.7-58.el7
Doc Type: Bug Fix
Doc Text:
Checking local mount availability with *autofs* no longer leads to a lengthy timeout before failing Previously, a server availability probe was not done for mount requests that *autofs* considered local because a bind mount on the local machine is expected to be available for use. If the bind mount failed, an NFS mount on the local machine was then tried. However, if the NFS server was not running on the local machine, the mount attempt sometimes suffered a lengthy timeout before failing. An availability probe has been added to the case where a bind mount is first tried, but fails, and *autofs* now falls back to trying to use an NFS server on the local machine. As a result, if a bind mount on the local machine fails, the fallback to trying an NFS mount on the local machine fails quickly if the local NFS server is not running.
Clone Of: 1396403
Last Closed: 2017-08-01 12:43:52 UTC
Target Upstream Version:

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2213 0 normal SHIPPED_LIVE autofs bug fix and enhancement update 2017-08-01 16:09:35 UTC

Comment 6 Yongcheng Yang 2017-06-16 05:31:44 UTC
The patch mentioned in Bug 1396403 comment #24 has already been
merged and no more issue is found during the regression tests.

As this problem cannot be reproduced, just verify it as "SanityOnly".

Comment 7 errata-xmlrpc 2017-08-01 12:43:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.