Bug 1420697 - CLI option "--timeout" is accepting non numeric and negative values.
Summary: CLI option "--timeout" is accepting non numeric and negative values.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1381158 1421017
TreeView+ depends on / blocked
 
Reported: 2017-02-09 10:29 UTC by Atin Mukherjee
Modified: 2017-05-30 18:42 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1381158
: 1421017 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:42:26 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-02-09 10:39:49 UTC
REVIEW: https://review.gluster.org/16578 (cli: add integer check for timeout option) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Worker Ant 2017-02-09 12:04:15 UTC
REVIEW: https://review.gluster.org/16578 (cli: add integer check for timeout option) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Worker Ant 2017-02-09 12:46:56 UTC
REVIEW: https://review.gluster.org/16578 (cli: add integer check for timeout option) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 4 Worker Ant 2017-02-09 14:23:27 UTC
REVIEW: https://review.gluster.org/16578 (cli: add integer check for timeout option) posted (#4) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 5 Worker Ant 2017-02-09 14:38:16 UTC
REVIEW: https://review.gluster.org/16578 (cli: add integer check for timeout option) posted (#5) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 6 Worker Ant 2017-02-10 06:16:39 UTC
COMMIT: https://review.gluster.org/16578 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 421a098d2acfd4b837d4c03ea6f69987c670d3f7
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Feb 9 16:09:08 2017 +0530

    cli: add integer check for timeout option
    
    Change-Id: Ia9f2d343e0a9ad13af1a62abe8946d646d36b3bb
    BUG: 1420697
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: https://review.gluster.org/16578
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-by: Samikshan Bairagya <samikshan@gmail.com>

Comment 7 Shyamsundar 2017-05-30 18:42:26 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.