Bug 1421017 - CLI option "--timeout" is accepting non numeric and negative values.
Summary: CLI option "--timeout" is accepting non numeric and negative values.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: 3.10
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On: 1420697
Blocks: 1381158
TreeView+ depends on / blocked
 
Reported: 2017-02-10 06:21 UTC by Atin Mukherjee
Modified: 2017-03-06 17:46 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1420697
Environment:
Last Closed: 2017-03-06 17:46:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2017-02-10 06:21:20 UTC
+++ This bug was initially created as a clone of Bug #1420697 +++

+++ This bug was initially created as a clone of Bug #1381158 +++

Description of problem:
=======================
Gluster CLI option "--timeout" is accepting  non numeric and negative values.

This option is introduced for the issue:  https://bugzilla.redhat.com/show_bug.cgi?id=1340338

Non Numeric value setting
[root@ ~]# gluster --timeout=xvafgs   volume  status replica inode
^Z
[1]+  Stopped                 gluster --timeout=xvafgs volume status replica inode
[root@ ~]# 

Negative value setting:
~]# gluster --timeout=-12  volume  status replica inode

^Z
[2]+  Stopped                 gluster --timeout=-12 volume status replica inode
[root@ ~]# 




Version-Release number of selected component (if applicable):
===========================================================
glusterfs-3.8.4-2


How reproducible:
=================
Always

Steps to Reproduce:
1. Use CLI option "--timeout=" with negative values and non numeric values.
2.
3.

Actual results:
===============
CLI option "--timeout" is accepting negative and non  numeric values 


Expected results:
================
It should accept only positive numeric values

Additional info:

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-10-03 05:28:29 EDT ---

This bug is automatically being proposed for the current release of Red Hat Gluster Storage 3 under active development, by setting the release flag 'rhgs‑3.2.0' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

--- Additional comment from John Skeoch on 2016-11-17 23:14:27 EST ---

User sashinde@redhat.com's account has been closed

--- Additional comment from Red Hat Bugzilla Rules Engine on 2017-01-01 12:24:52 EST ---

This BZ having been considered, and subsequently not approved to be fixed at the RHGS 3.2.0 release, is being proposed for the next release of RHGS

--- Additional comment from Worker Ant on 2017-02-09 05:39:49 EST ---

REVIEW: https://review.gluster.org/16578 (cli: add integer check for timeout option) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Worker Ant on 2017-02-09 07:04:15 EST ---

REVIEW: https://review.gluster.org/16578 (cli: add integer check for timeout option) posted (#2) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Worker Ant on 2017-02-09 07:46:56 EST ---

REVIEW: https://review.gluster.org/16578 (cli: add integer check for timeout option) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Worker Ant on 2017-02-09 09:23:27 EST ---

REVIEW: https://review.gluster.org/16578 (cli: add integer check for timeout option) posted (#4) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Worker Ant on 2017-02-09 09:38:16 EST ---

REVIEW: https://review.gluster.org/16578 (cli: add integer check for timeout option) posted (#5) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Worker Ant on 2017-02-10 01:16:39 EST ---

COMMIT: https://review.gluster.org/16578 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 421a098d2acfd4b837d4c03ea6f69987c670d3f7
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Feb 9 16:09:08 2017 +0530

    cli: add integer check for timeout option
    
    Change-Id: Ia9f2d343e0a9ad13af1a62abe8946d646d36b3bb
    BUG: 1420697
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: https://review.gluster.org/16578
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Reviewed-by: Samikshan Bairagya <samikshan@gmail.com>

Comment 1 Worker Ant 2017-02-10 06:23:16 UTC
REVIEW: https://review.gluster.org/16595 (cli: add integer check for timeout option) posted (#1) for review on release-3.10 by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Worker Ant 2017-02-10 11:40:32 UTC
COMMIT: https://review.gluster.org/16595 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 2a596acfd054afda5234083b675d5fd4bc171a21
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Feb 9 16:09:08 2017 +0530

    cli: add integer check for timeout option
    
    >Reviewed-on: https://review.gluster.org/16578
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Prashanth Pai <ppai@redhat.com>
    >Reviewed-by: Samikshan Bairagya <samikshan@gmail.com>
    >(cherry picked from commit 421a098d2acfd4b837d4c03ea6f69987c670d3f7)
    
    Change-Id: Ia9f2d343e0a9ad13af1a62abe8946d646d36b3bb
    BUG: 1421017
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: https://review.gluster.org/16595
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 3 Shyamsundar 2017-03-06 17:46:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.