Bug 1420698 - Unable to provision rbd volumes in containerized OpenShift, "err: executable file not found in $PATH"
Summary: Unable to provision rbd volumes in containerized OpenShift, "err: executable ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: hchen
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On: 1411244 1422348 1422638
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 10:31 UTC by Jianwei Hou
Modified: 2017-07-24 14:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: ceph-common packages not installed in infra container. Consequence: failed to provision ceph RBD volumes Fix: install ceph-common packages in infra container. Result: ceph RBD volumes now provision.
Clone Of: 1411244
Environment:
Last Closed: 2017-04-12 19:12:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Origin (Github) 12896 None None None 2017-02-22 16:39:25 UTC
Origin (Github) 13060 None None None 2017-02-27 19:34:55 UTC
Red Hat Product Errata RHBA-2017:0884 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Comment 1 Jianwei Hou 2017-02-09 10:33:14 UTC
This bug is reproduced in 

openshift v3.5.0.18+9a5d1aa
kubernetes v1.5.2+43a9be4
etcd 3.1.0

Comment 4 Troy Dawson 2017-02-10 22:52:51 UTC
This has been merged into ocp and is in OCP v3.5.0.19 or newer.

Comment 6 Jianwei Hou 2017-02-21 03:22:30 UTC
Installation team has shared an environment that worked around the blocker bug, so I have tested this on:
openshift v3.5.0.32-1+4f84c83
kubernetes v1.5.2+43a9be4
etcd 3.1.0

[root@ip-172-18-9-64 ~]# docker images|grep openshift
registry.ops.openshift.com/openshift3/node          v3.5.0.32           aee6bbe19956        7 hours ago         940.9 MB
registry.ops.openshift.com/openshift3/openvswitch   v3.5.0.32           c0e8fcf571bc        7 hours ago         302.2 MB
registry.ops.openshift.com/openshift3/ose           v3.5                92b2ec9e46b0        7 hours ago         632 MB
registry.ops.openshift.com/openshift3/ose           v3.5.0.32           92b2ec9e46b0        7 hours ago         632 MB

This bug is still reproducible.
[root@ip-172-18-9-64 ~]# oc describe pvc cephrbdprovisioner -n default
Name:           cephrbdprovisioner
Namespace:      default
StorageClass:   cephrbdprovisioner
Status:         Pending
Volume:
Labels:         <none>
Capacity:
Access Modes:
Events:
  FirstSeen     LastSeen        Count   From                            SubObjectPath   Type            Reason                  Message
  ---------     --------        -----   ----                            -------------   --------        ------                  -------
  12m           8s              52      {persistentvolume-controller }                  Warning         ProvisioningFailed      Failed to provision volume with StorageClass "cephrbdprovisioner": rbd: create volume failed, err: executable file not found in $PATH

Comment 10 Jianwei Hou 2017-02-28 05:33:00 UTC
Tested this is fixed in v3.5.0.35

Comment 11 Troy Dawson 2017-03-01 23:02:37 UTC
This has been merged into ocp and is in OCP v3.5.0.37 or newer.

Comment 12 Jianwei Hou 2017-03-02 11:04:41 UTC
Verified this is fixed in v3.5.0.37

Comment 14 errata-xmlrpc 2017-04-12 19:12:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.