Bug 1422348 - lib_openshift role not working for containerized env installation
Summary: lib_openshift role not working for containerized env installation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Gaoyun Pei
URL:
Whiteboard:
Depends On: 1422638
Blocks: 1420698
TreeView+ depends on / blocked
 
Reported: 2017-02-15 04:34 UTC by Gaoyun Pei
Modified: 2017-07-24 14:11 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1422638 (view as bug list)
Environment:
Last Closed: 2017-03-08 14:07:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0903 0 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix and enhancement 2017-04-12 22:45:42 UTC

Description Gaoyun Pei 2017-02-15 04:34:39 UTC
Description of problem:
Role lib_openshift want to install python-ruamel-yaml package on target hosts, but this action would fail on AtomicHost.

It would also be failed when installing containerized env on RHEL machine without ocp repo configured.


Version-Release number of selected component (if applicable):
openshift-ansible-3.5.8-1.git.0.0e02ef8.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1. Trigger an installation on AtomicHost

TASK [lib_openshift : lib_openshift ensure python-ruamel-yaml package is on target] ***
Wednesday 15 February 2017  03:09:43 +0000 (0:00:00.601)       0:08:31.670 **** 
fatal: [gpei-35-test-master-1.0215-8ym.qe.rhcloud.com]: FAILED! => {
    "changed": false, 
    "failed": true
}

MSG:

Could not find a module for unknown.


2. Trigger a containerized installation on RHEL without ocp repo configured

TASK [lib_openshift : lib_openshift ensure python-ruamel-yaml package is on target] ***
Wednesday 15 February 2017  03:06:19 +0000 (0:00:00.643)       0:13:45.777 **** fatal: [ec2-54-210-48-22.compute-1.amazonaws.com]: FAILED! => {"changed": false, "failed": true, "msg": "No package matching 'python-ruamel-yaml' found available, installed or updated", "rc": 126, "results": ["No package matching 'python-ruamel-yaml' found available, installed or updated"]}


Actual results:


Expected results:


Additional info:

Comment 1 Gaoyun Pei 2017-02-15 04:46:08 UTC
Since this bug is blocking containerized installation on RHEL and AtomicHost, add TestBlocker keyword.

Comment 2 liujia 2017-02-15 09:43:42 UTC
Upgrade against atomic hosts hit the same issue.

Comment 6 Gaoyun Pei 2017-02-17 10:35:59 UTC
Test this bug with openshift-ansible-3.5.10-1.git.0.ba66b63.el7.noarch.rpm

It's working well on AtomicHost, but for containerized installation on RHEL, we usually won't configure ocp repo in addition, so it still fail for python-ruamel-yaml not available.

TASK [lib_openshift : lib_openshift ensure python-ruamel-yaml package is on target] ***
Friday 17 February 2017  10:12:32 +0000 (0:00:00.644)       0:18:40.374 ******* 
fatal: [ec2-54-85-116-101.compute-1.amazonaws.com]: FAILED! => {
    "changed": false, 
    "failed": true, 
    "rc": 126, 
    "results": [
        "No package matching 'python-ruamel-yaml' found available, installed or updated"
    ]
}

MSG:

No package matching 'python-ruamel-yaml' found available, installed or updated

Comment 7 Gaoyun Pei 2017-02-21 02:46:33 UTC
For containerized installation on RHEL, we're adding ocp repo additionally to avoid this issue, so remove the TestBlocker keyword and lower the Severity&Priority

Comment 8 Scott Dodson 2017-02-24 21:45:29 UTC
https://github.com/openshift/openshift-ansible/pull/3406 should've fixed this and is in current builds.

Comment 9 Gaoyun Pei 2017-02-27 10:12:27 UTC
Tried containerized installation on RHEL-7.3 with openshift-ansible-3.5.15-1.git.0.8d2a456.el7.noarch.rpm

When ocp-3.5 repo configured in openshift_additional_repos, installer could configure the repo on target host and install python-ruamel-yaml package.

But QE still think we shouldn't enable ocp repo when performing a containerized installation, ose images should provide all we needed, maybe we could have a better solution on it. Thanks.

Comment 10 Scott Dodson 2017-02-27 13:24:22 UTC
Ok, we'll avoid python-ruamel-yaml on containerized installs until we have a decent solution for providing python deps.

Comment 13 Gaoyun Pei 2017-03-07 09:20:54 UTC
Verify this bug with openshift-ansible-3.5.25-1.git.0.a40beae.el7.noarch.rpm

Containerized installation on RHEL-7.3 without ocp-3.5 repo configured on the hosts is successful, thanks for the fix!


Note You need to log in before you can comment on or make changes to this bug.