Bug 1420712 - updateBackingContent CLI operation is not blocking and following retrieveBackingContent returns older content for some time
Summary: updateBackingContent CLI operation is not blocking and following retrieveBack...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Content
Version: JON 3.3.7,JON 3.3.8
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: CR01
: JON 3.3.9
Assignee: Ruben Vargas Palma
QA Contact: Hayk Hovsepyan
URL:
Whiteboard:
Depends On:
Blocks: 1420717
TreeView+ depends on / blocked
 
Reported: 2017-02-09 11:25 UTC by Filip Brychta
Modified: 2017-10-02 17:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-02 17:21:51 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1420717 0 medium CLOSED When calling retrieveBackingContent cli operation immediately after updateBackingContent it sometimes fails with NPE 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHEA-2017:2846 0 normal SHIPPED_LIVE Red Hat JBoss Operations Network 3.3.9 bug fix update 2017-10-02 21:21:28 UTC

Internal Links: 1420717

Description Filip Brychta 2017-02-09 11:25:29 UTC
Description of problem:
When retrieving backing contend immediately after updateBackingContent it will return older content. It's necessary to wait for some time before it retrieves correct new content.

Version-Release number of selected component (if applicable):
JON 3.3.8, 3.3.7 but probably in previous versions as well

How reproducible:
Always

Steps to Reproduce:
1. crate new eap6 deployment
2. update content via cli operation updateBackingContent, use deployment at least with size 1MB
3. immediately invoke retrieveBackingContent

Actual results:
retrieveBackingContent will return old content created in step 1

Expected results:
Either updateBackingContent should be blocking or there should be some way how to wait for the operation to be finished

Comment 3 Simeon Pinder 2017-09-19 11:33:13 UTC
Moving to ON_QA.

JON 3.3.9 CR01 artifacts are available for test from here:
http://download.eng.bos.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.3.0.GA/135/maven/org/jboss/on/jon-server-patch/3.3.0.GA/jon-server-patch-3.3.0.GA.zip
 *Note: jon-server-patch-3.3.0.GA.zip maps to CR01 build of
 jon-server-3.3.0.GA-update-09.zip.

Comment 4 Hayk Hovsepyan 2017-09-21 13:09:52 UTC
Verified on:
Version : 3.3.0.GA Update 09
Build Number :	44ba698:204e925

Immediately after "updateBackingContent" execution, when "retrieveBackingContent" is executed, it retrieves the updated deployment without any error in CLI or in server log.

Comment 5 errata-xmlrpc 2017-10-02 17:21:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2846


Note You need to log in before you can comment on or make changes to this bug.