Bug 1420717 - When calling retrieveBackingContent cli operation immediately after updateBackingContent it sometimes fails with NPE
Summary: When calling retrieveBackingContent cli operation immediately after updateBac...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Content
Version: JON 3.3.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: CR01
: JON 3.3.9
Assignee: Ruben Vargas Palma
QA Contact: Hayk Hovsepyan
URL:
Whiteboard:
Depends On: 1420712
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 11:34 UTC by Filip Brychta
Modified: 2017-10-02 17:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-02 17:21:51 UTC
Type: Bug


Attachments (Terms of Use)
server log (41.24 KB, text/plain)
2017-02-09 11:34 UTC, Filip Brychta
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1420712 None None None Never
Red Hat Product Errata RHEA-2017:2846 normal SHIPPED_LIVE Red Hat JBoss Operations Network 3.3.9 bug fix update 2017-10-02 21:21:28 UTC

Internal Links: 1420712

Description Filip Brychta 2017-02-09 11:34:11 UTC
Created attachment 1248788 [details]
server log

Description of problem:
$Summary

Version-Release number of selected component (if applicable):
JON 3.3.8 but probably in earlier versions as well. The line with NPE was updated 7 years ago

How reproducible:
just once

Steps to Reproduce:
1. crate new eap6 deployment
2. update content via cli operation updateBackingContent, use deployment at least with size 1MB
3. immediately invoke retrieveBackingContent
4. repeat steps 2 and 3 many times

Actual results:
Caused by: java.lang.NullPointerException
	at org.rhq.enterprise.server.content.ContentManagerBean.getPackageBytes(ContentManagerBean.java:952)


Expected results:
No errors

Additional info:
Full exception is attached in server.log

Comment 4 Simeon Pinder 2017-09-19 11:33:16 UTC
Moving to ON_QA.

JON 3.3.9 CR01 artifacts are available for test from here:
http://download.eng.bos.redhat.com/brewroot/packages/org.jboss.on-jboss-on-parent/3.3.0.GA/135/maven/org/jboss/on/jon-server-patch/3.3.0.GA/jon-server-patch-3.3.0.GA.zip
 *Note: jon-server-patch-3.3.0.GA.zip maps to CR01 build of
 jon-server-3.3.0.GA-update-09.zip.

Comment 5 Hayk Hovsepyan 2017-09-21 13:09:38 UTC
Verified on:
Version : 3.3.0.GA Update 09
Build Number :	44ba698:204e925

Immediately after "updateBackingContent" execution, when "retrieveBackingContent" is executed, it retrieves the updated deployment without any error in CLI or in server log.

Comment 6 errata-xmlrpc 2017-10-02 17:21:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2846


Note You need to log in before you can comment on or make changes to this bug.