Bug 1420751 - impossible to log in
Summary: impossible to log in
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Stefanie Forrester
QA Contact: Chuan Yu
URL:
Whiteboard:
: 1421379 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-09 13:12 UTC by dbb2000
Modified: 2019-03-29 15:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-13 22:27:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
print screen as example about the issue. (309.48 KB, image/png)
2017-02-09 13:12 UTC, dbb2000
no flags Details

Description dbb2000 2017-02-09 13:12:37 UTC
Created attachment 1248809 [details]
print screen as example about the issue.

I received an e-mail telling me my account creation is ready, but I try to access the console using "console.preview.openshift.com" and the following message is shown to me: "You do not have access to the Developer Preview. If you have already requested access you will receive an email when you are approved. "

I don't understand because I already received that e-mail and I'm trying to log in with my GIT HUB account.

Thanks for any help.

Comment 1 thetacco 2017-02-09 14:33:27 UTC
Same here... but also, when I try to register again I get prompted that I already have access and can login "here"...where I see the "You don't have access".

Thanks also.

Comment 2 dbb2000 2017-02-09 14:44:32 UTC
Yes I also experienced the same as you.

Comment 4 Stefanie Forrester 2017-02-09 21:17:28 UTC
This seems to be related to yesterday's update. I'm running an etcd data migration on the affected users to restore their ability to log in. It could take a few hours to complete.

Comment 5 Stefanie Forrester 2017-02-09 22:03:38 UTC
The migration has completed. We'll keep monitoring for issues. Please update this bug if you're still unable to log in.

Comment 6 micha.van.santvoort 2017-02-10 07:50:54 UTC
I still have the same problem.  I cannot login.

I was registered 10days ago, and since yesterday morning I always get 
"You do not have access to the Developer Preview. If you have already requested access you will receive an email when you are approved.
Request access"

If I Request access again, I get the message 
"You already have access to the Developer Preview. You can log-in at https://console.preview.openshift.com/."

So I'm in a loop there.

My deployed application is still running and I can access via OC, but I'm not sure what will happen when I do OC logout?

Comment 7 Jordan Liggitt 2017-02-11 20:26:19 UTC
*** Bug 1421379 has been marked as a duplicate of this bug. ***

Comment 8 dbb2000 2017-02-11 21:50:27 UTC
it seems to be ok for my now. Thanks

Comment 9 Stefanie Forrester 2017-02-13 14:34:05 UTC
(In reply to micha.van.santvoort from comment #6)
> I still have the same problem.  I cannot login.

Your user account was missing an object in our system known as a useridentitymapping. I have recreated your missing useridentitymapping, along with 206 other missing mappings I found. Let me know if you're still having any login trouble.

I think this has resolved any remaining login issues.

Comment 10 Peter Miklos 2017-02-13 16:23:19 UTC
Hi! I still cannot log in from the same reason. My user is pmiklos, could you please take a look? Thank you in advance!

Comment 11 Peter Miklos 2017-02-13 20:17:18 UTC
It's working now, thank you.

Comment 12 Abhishek Gupta 2017-02-13 22:27:45 UTC
This issue should now be resolved. Please reopen if someone is still facing an issue logging in.

Comment 13 micha.van.santvoort 2017-02-14 11:42:10 UTC
Indeed, problem fixed (for me)
Tx


Note You need to log in before you can comment on or make changes to this bug.