Bug 1420987 - warning messages seen in glusterd logs while setting the volume option
Summary: warning messages seen in glusterd logs while setting the volume option
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.10
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On: 1420614
Blocks: 1326183 1345718
TreeView+ depends on / blocked
 
Reported: 2017-02-10 04:29 UTC by Atin Mukherjee
Modified: 2017-03-06 17:45 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1420614
Environment:
Last Closed: 2017-03-06 17:45:52 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2017-02-10 04:29:45 UTC
+++ This bug was initially created as a clone of Bug #1420614 +++

+++ This bug was initially created as a clone of Bug #1326183 +++

Description of problem:
-----------------------
Noticed the warning messages in glusterd logs after setting an volume option.
The warning message is as follows :
<snip>
[2016-04-11 16:48:34.823961] W [dict.c:1452:dict_get_with_ref] (-->/usr/lib64/glusterfs/3.7.9/xlator/mgmt/glusterd.so(build_shd_graph+0x69) [0x7fdc0c3f3039] -->/lib64/libglusterfs.so.0(dict_get_str_boolean+0x32) [0x7fdc17830fe2] -->/lib64/libglusterfs.so.0(+0x1eba6) [0x7fdc1782eba6] ) 0-dict: dict OR key (graph-check) is NULL [Invalid argument]
[2016-04-11 16:48:34.824844] W [dict.c:1452:dict_get_with_ref] (-->/usr/lib64/glusterfs/3.7.9/xlator/mgmt/glusterd.so(build_shd_graph+0x69) [0x7fdc0c3f3039] -->/lib64/libglusterfs.so.0(dict_get_str_boolean+0x32) [0x7fdc17830fe2] -->/lib64/libglusterfs.so.0(+0x1eba6) [0x7fdc1782eba6] ) 0-dict: dict OR key (graph-check) is NULL [Invalid argument]

</snip> 


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.1.3 nightly build ( glusterfs-3.7.9-1.el7rhgs )

How reproducible:
------------------
consistent

Steps to Reproduce:
-------------------
1. Create any type of volume
2. Set any volume option on the volume
3. Observe glusterd logs

Actual results:
---------------
Warning messages seen in glusterd logs

Expected results:
-----------------
There shouldn't be any warning messages

--- Additional comment from SATHEESARAN on 2016-04-12 01:39:17 EDT ---

Below is the snip from Ravishankar ( AFR ) on this issue :

<snip>
Don't see any recent changes, but the builder (i.e. build_shd_graph()) is dict-getting a "graph-check" key from mod_dict and I see many places in the code where builders are launched via glusterd_create_global_volfile() with NULL dicts. So maybe a null check for dict in build_shd_graph() is sufficient.
</snip>

--- Additional comment from Red Hat Bugzilla Rules Engine on 2016-07-04 04:53:14 EDT ---

This bug is automatically being proposed for the current z-stream release of Red Hat Gluster Storage 3 by setting the release flag 'rhgs‑3.1.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

--- Additional comment from Rejy M Cyriac on 2016-09-17 12:34:39 EDT ---

Moving BZ to a transitional component in preparation for removing the 'glusterd' sub-component at the 'glusterd' component

--- Additional comment from Rejy M Cyriac on 2016-09-17 12:47:53 EDT ---

Moving BZ back to the 'glusterd' component after removal of the 'glusterd' sub-component

--- Additional comment from Worker Ant on 2017-02-09 00:00:23 EST ---

REVIEW: https://review.gluster.org/16573 (glusterd: put null check for mod_dict in build_shd_graph) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

--- Additional comment from Worker Ant on 2017-02-09 11:19:47 EST ---

COMMIT: https://review.gluster.org/16573 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 824a48fb5ce20e26ed78b26afd81ec876bc826ec
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Feb 9 10:28:55 2017 +0530

    glusterd: put null check for mod_dict in build_shd_graph
    
    Change-Id: I849f5f7eb5932d2dc2a76f8abc61e41231f9883e
    BUG: 1420614
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: https://review.gluster.org/16573
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 1 Worker Ant 2017-02-10 04:30:25 UTC
REVIEW: https://review.gluster.org/16590 (glusterd: put null check for mod_dict in build_shd_graph) posted (#1) for review on release-3.10 by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Worker Ant 2017-02-10 05:09:26 UTC
REVIEW: https://review.gluster.org/16590 (glusterd: put null check for mod_dict in build_shd_graph) posted (#2) for review on release-3.10 by Atin Mukherjee (amukherj@redhat.com)

Comment 3 Worker Ant 2017-02-10 14:05:31 UTC
COMMIT: https://review.gluster.org/16590 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit e9ca84fc977817b2709ab553837dd0d49a23ad34
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Thu Feb 9 10:28:55 2017 +0530

    glusterd: put null check for mod_dict in build_shd_graph
    
    >Reviewed-on: https://review.gluster.org/16573
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Prashanth Pai <ppai@redhat.com>
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >(cherry picked from commit 824a48fb5ce20e26ed78b26afd81ec876bc826ec)
    
    Change-Id: I849f5f7eb5932d2dc2a76f8abc61e41231f9883e
    BUG: 1420987
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: https://review.gluster.org/16590
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 4 Shyamsundar 2017-03-06 17:45:52 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.