Bug 1421137 - Unable to take Statedump for gfapi applications
Summary: Unable to take Statedump for gfapi applications
Keywords:
Status: CLOSED DUPLICATE of bug 1378085
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: libgfapi
Version: rhgs-3.3
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
: ---
Assignee: Soumya Koduri
QA Contact: surabhi
URL:
Whiteboard:
Depends On: 1169302
Blocks: 1378085 1418981 1436678
TreeView+ depends on / blocked
 
Reported: 2017-02-10 12:21 UTC by Soumya Koduri
Modified: 2017-03-28 12:38 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1169302
Environment:
Last Closed: 2017-02-10 12:30:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github https://github.com/gluster/glusterfs/milestone/1 0 None None None 2017-02-10 12:21:56 UTC

Description Soumya Koduri 2017-02-10 12:21:57 UTC
+++ This bug was initially created as a clone of Bug #1169302 +++

Description of problem:
Unable to take Statedump for gfapi applications

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2014-12-02 01:54:47 EST ---

REVIEW: http://review.gluster.org/9228 (libgfapi: statedump support) posted (#1) for review on master by Poornima G (pgurusid@redhat.com)

--- Additional comment from Anand Avati on 2014-12-03 02:11:58 EST ---

REVIEW: http://review.gluster.org/9228 (libgfapi: statedump support) posted (#2) for review on master by Poornima G (pgurusid@redhat.com)

--- Additional comment from Anand Avati on 2015-01-05 05:54:21 EST ---

REVIEW: http://review.gluster.org/9228 (libgfapi: statedump support) posted (#3) for review on master by Poornima G (pgurusid@redhat.com)

--- Additional comment from Kaleb KEITHLEY on 2015-10-22 11:40:20 EDT ---

pre-release version is ambiguous and about to be removed as a choice.

If you believe this is still a bug, please change the status back to NEW and choose the appropriate, applicable version for it.

--- Additional comment from Vijay Bellur on 2016-01-28 01:46:57 EST ---

REVIEW: http://review.gluster.org/9228 (libgfapi: Implement statedump) posted (#4) for review on master by Poornima G (pgurusid@redhat.com)

--- Additional comment from Vijay Bellur on 2016-03-16 05:37:53 EDT ---

REVIEW: http://review.gluster.org/9228 (libgfapi: Implement statedump) posted (#5) for review on master by Poornima G (pgurusid@redhat.com)

--- Additional comment from Vijay Bellur on 2016-07-20 01:44:13 EDT ---

REVIEW: http://review.gluster.org/9228 (libgfapi: Implement statedump) posted (#6) for review on master by Poornima G (pgurusid@redhat.com)

--- Additional comment from Worker Ant on 2017-01-06 01:05:36 EST ---

REVIEW: http://review.gluster.org/9228 (libgfapi: Implement statedump) posted (#7) for review on master by Poornima G (pgurusid@redhat.com)

--- Additional comment from Worker Ant on 2017-01-09 00:48:55 EST ---

REVIEW: http://review.gluster.org/9228 (libgfapi: Implement statedump) posted (#8) for review on master by Poornima G (pgurusid@redhat.com)

--- Additional comment from Worker Ant on 2017-01-15 14:30:52 EST ---

REVIEW: http://review.gluster.org/9228 (glusterd: add a cli command to trigger a statedump on a client) posted (#9) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-15 14:30:56 EST ---

REVIEW: http://review.gluster.org/16414 (gfapi: add API to trigger events for debugging and troubleshooting) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-15 14:30:59 EST ---

REVIEW: http://review.gluster.org/16415 (gfapi: create statedump when glusterd requests it) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-17 08:33:12 EST ---

REVIEW: http://review.gluster.org/9228 (glusterd: add a cli command to trigger a statedump on a client) posted (#10) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-17 08:33:16 EST ---

REVIEW: http://review.gluster.org/16415 (gfapi: create statedump when glusterd requests it) posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-17 08:33:19 EST ---

REVIEW: http://review.gluster.org/16414 (gfapi: add API to trigger events for debugging and troubleshooting) posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-17 10:20:56 EST ---

REVIEW: http://review.gluster.org/16415 (gfapi: create statedump when glusterd requests it) posted (#3) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-19 13:10:40 EST ---

REVIEW: http://review.gluster.org/9228 (glusterd: add a cli command to trigger a statedump on a client) posted (#11) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-19 13:10:43 EST ---

REVIEW: http://review.gluster.org/16415 (gfapi: create statedump when glusterd requests it) posted (#4) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-19 13:44:27 EST ---

COMMIT: http://review.gluster.org/16414 committed in master by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit d93a6691538270aefe7703e8f8d7c822f53528e5
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Jan 6 12:49:32 2017 +0100

    gfapi: add API to trigger events for debugging and troubleshooting
    
    Introduce glfs_sysrq() as a generic API for triggering debug and
    troubleshoot events. This interface will be used by the feature to get
    statedumps for applications using libgfapi.
    
    The current events that can be requested through this API are:
     - 'h'elp: log a mesage with all supported events
     - 's'tatedump: trigger a statedump for the passed glfs_t
    
    In future, this API can be used by a CLI to trigger statedumps from
    storage servers. At the moment it is limited to take statedumps, but it
    is extensible to set the log-level, clear caches, force reconnects and
    much more.
    
    BUG: 1169302
    Change-Id: I18858359a3957870cea5139c79efe1365a15a992
    Original-author: Poornima G <pgurusid@redhat.com>
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/16414
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

--- Additional comment from Worker Ant on 2017-01-19 16:33:22 EST ---

REVIEW: http://review.gluster.org/16415 (gfapi: create statedump when glusterd requests it) posted (#5) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-20 06:05:46 EST ---

REVIEW: http://review.gluster.org/9228 (glusterd: add a cli command to trigger a statedump on a client) posted (#12) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-20 06:05:50 EST ---

REVIEW: http://review.gluster.org/16415 (gfapi: create statedump when glusterd requests it) posted (#6) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-20 06:27:19 EST ---

REVIEW: http://review.gluster.org/16415 (gfapi: create statedump when glusterd requests it) posted (#7) for review on master by Niels de Vos (ndevos@redhat.com)

--- Additional comment from Worker Ant on 2017-01-20 06:41:48 EST ---

REVIEW: http://review.gluster.org/16415 (gfapi: create statedump when glusterd requests it) posted (#8) for review on master by Niels de Vos (ndevos@redhat.com)

Comment 2 Atin Mukherjee 2017-02-10 12:30:49 UTC

*** This bug has been marked as a duplicate of bug 1378085 ***


Note You need to log in before you can comment on or make changes to this bug.