Bug 1418981 - Unable to take Statedump for gfapi applications
Summary: Unable to take Statedump for gfapi applications
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On: 1169302 1378085 1421137
Blocks: glusterfs-3.10.0
TreeView+ depends on / blocked
 
Reported: 2017-02-03 10:52 UTC by Niels de Vos
Modified: 2017-03-28 12:42 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: Enhancement
Doc Text:
Clone Of: 1169302
Environment:
Last Closed: 2017-02-27 15:28:49 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github https://github.com/gluster/glusterfs/milestone/1 0 None None None 2017-02-03 10:52:02 UTC

Description Niels de Vos 2017-02-03 10:52:02 UTC
+++ This bug was initially created as a clone of Bug #1169302 +++

Description of problem:
Unable to take Statedump for gfapi applications

Patches to backport are on https://review.gluster.org/#/q/topic:bug-1169302

Comment 1 Worker Ant 2017-02-10 20:26:54 UTC
REVIEW: https://review.gluster.org/16600 (gfapi: add API to trigger events for debugging and troubleshooting) posted (#1) for review on release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com)

Comment 2 Worker Ant 2017-02-10 20:26:57 UTC
REVIEW: https://review.gluster.org/16601 (glusterd: add a cli command to trigger a statedump on a client) posted (#1) for review on release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com)

Comment 3 Worker Ant 2017-02-10 20:27:06 UTC
REVIEW: https://review.gluster.org/16602 (gfapi: create statedump when glusterd requests it) posted (#1) for review on release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com)

Comment 4 Worker Ant 2017-02-13 13:29:07 UTC
REVIEW: https://review.gluster.org/16601 (glusterd: add a cli command to trigger a statedump on a client) posted (#2) for review on release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com)

Comment 5 Worker Ant 2017-02-13 13:31:05 UTC
REVIEW: https://review.gluster.org/16600 (gfapi: add API to trigger events for debugging and troubleshooting) posted (#2) for review on release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com)

Comment 6 Worker Ant 2017-02-14 01:53:14 UTC
COMMIT: https://review.gluster.org/16601 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 99ce0d43fffa9b2094edcd4917df2ff9ca7afe5d
Author: Poornima G <pgurusid@redhat.com>
Date:   Fri Jan 22 11:44:21 2016 -0500

    glusterd: add a cli command to trigger a statedump on a client
    
    With this, we will be able to trigger statedumps on remote Gluster
    clients, mainly targetted for applications using libgfapi.
    
    Design:
    SIGUSR signal is the most comman way of taking a statedump in Gluster.
    But it cannot be used for libgfapi based processes, as the process
    loading the library might have already consumed SIGUSR signal. Hence
    going by the command way.
    
    One has to issue a Gluster command to initiate a statedump on the
    libgfapi based client. The command takes hostname and PID as an
    argument. All the glusterds in the cluster, check if they are connected
    to the specified hostname, and send an RPC request to all the connected
    clients from that hostname (via the mgmt connection).
    
    > URL: http://review.gluster.org/16357
    > BUG: 1169302
    > Signed-off-by: Poornima G <pgurusid@redhat.com>
    > [ndevos: minor fixes and split patch in smaller pieces]
    > Reviewed-on-master: https://review.gluster.org/9228
    > Reviewed-by: Niels de Vos <ndevos@redhat.com>
    > Tested-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    > Reviewed-by: Samikshan Bairagya <samikshan@gmail.com>
    
    BUG: 1418981
    Change-Id: Icbe4d2f026b32a2c7d5535e1bfb2cdaaff042e91
    Signed-off-by: Shyam <srangana@redhat.com>
    Reviewed-on: https://review.gluster.org/16601
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 7 Worker Ant 2017-02-14 01:53:27 UTC
COMMIT: https://review.gluster.org/16600 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit bd9adf99a2ca53dd18332957acb465f904ecd22c
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Jan 6 12:49:32 2017 +0100

    gfapi: add API to trigger events for debugging and troubleshooting
    
    Introduce glfs_sysrq() as a generic API for triggering debug and
    troubleshoot events. This interface will be used by the feature to get
    statedumps for applications using libgfapi.
    
    The current events that can be requested through this API are:
     - 'h'elp: log a mesage with all supported events
     - 's'tatedump: trigger a statedump for the passed glfs_t
    
    In future, this API can be used by a CLI to trigger statedumps from
    storage servers. At the moment it is limited to take statedumps, but it
    is extensible to set the log-level, clear caches, force reconnects and
    much more.
    
    > BUG: 1169302
    > Change-Id: I18858359a3957870cea5139c79efe1365a15a992
    > Original-author: Poornima G <pgurusid@redhat.com>
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-on-master: http://review.gluster.org/16414
    > Reviewed-by: Prashanth Pai <ppai@redhat.com>
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    
    BUG: 1418981
    Change-Id: I18858359a3957870cea5139c79efe1365a15a992
    Signed-off-by: Shyam <srangana@redhat.com>
    Reviewed-on: https://review.gluster.org/16600
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 8 Worker Ant 2017-02-14 01:53:31 UTC
COMMIT: https://review.gluster.org/16602 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 48dc0655e214d8e4d313ebf86b5aabf3dc4b078a
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Jan 6 12:58:02 2017 +0100

    gfapi: create statedump when glusterd requests it
    
    When GlusterD sends the STATEDUMP procedure to the libgfapi client, the
    client checks if it matches the PID that should take the statedump. If
    so, it will do a statedump for the glfs_t that is connected to this mgmt
    connection.
    
    > BUG: 1169302
    > See-also: http://review.gluster.org/9228
    > Signed-off-by: Poornima G <pgurusid@redhat.com>
    > [ndevos: separated patch from 9228]
    > Reviewed-on: https://review.gluster.org/16415
    > Reviewed-by: Niels de Vos <ndevos@redhat.com>
    > Tested-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    > Reviewed-by: Prashanth Pai <ppai@redhat.com>
    
    BUG: 1418981
    Change-Id: I70d6a1f4f19d525377aebc8fa57f51e513b92d84
    Signed-off-by: Shyam <srangana@redhat.com>
    Reviewed-on: https://review.gluster.org/16602
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 9 Worker Ant 2017-02-22 19:05:35 UTC
REVIEW: https://review.gluster.org/16723 (gfapi: OBS build fails in post build analysis) posted (#1) for review on release-3.10 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 10 Worker Ant 2017-02-23 19:15:25 UTC
COMMIT: https://review.gluster.org/16723 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit d2a3a8f520068dc4e3cb49e2fa49afddb7c5dec7
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Feb 22 14:02:43 2017 -0500

    gfapi: OBS build fails in post build analysis
    
    Originally gfapi: create statedump when glusterd requests it
    
    When GlusterD sends the STATEDUMP procedure to the libgfapi client, the
    client checks if it matches the PID that should take the statedump. If
    so, it will do a statedump for the glfs_t that is connected to this mgmt
    connection.
    
    See https://bugzilla.redhat.com/show_bug.cgi?id=1169302#c25 for the
    OpenSuSE Build System post build analysis error.
    
    original Change-Id: I70d6a1f4f19d525377aebc8fa57f51e513b92d84
    master       https://review.gluster.org/#/c/16415/
    release-3.10 https://review.gluster.org/#/c/16602/
    
    BUG: 1418981
    Change-Id: I1cff59ed34ac963334416d4271f7a187cd88bff6
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: https://review.gluster.org/16723
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 11 Shyamsundar 2017-02-23 19:22:43 UTC
OBS build fix is not present in RC1 other fixes are

Comment 12 Shyamsundar 2017-02-27 15:28:49 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-devel/2017-February/052173.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 13 Shyamsundar 2017-03-06 17:45:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.