Bug 1421143 - New theme makes it difficult to read firefox input controls
Summary: New theme makes it difficult to read firefox input controls
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 13:19 UTC by Manilal
Modified: 2017-04-24 14:20 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-24 14:20:26 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot of Firefox location bar (67.62 KB, image/png)
2017-02-10 13:19 UTC, Manilal
no flags Details
Screenshot of a site's login box with values (38.62 KB, image/png)
2017-02-10 13:20 UTC, Manilal
no flags Details
Screenshot of Google Sheets on Firefox (20.79 KB, image/png)
2017-02-10 13:38 UTC, Manilal
no flags Details
Screenshot of Firefox location bar - Fixed (40.17 KB, image/png)
2017-03-30 06:18 UTC, Manilal
no flags Details
Screenshot of login page - fixed (42.43 KB, image/png)
2017-03-30 06:32 UTC, Manilal
no flags Details
Screenshot of Google Sheet - Fixed (10.52 KB, image/png)
2017-03-30 06:33 UTC, Manilal
no flags Details

Description Manilal 2017-02-10 13:19:55 UTC
Created attachment 1249035 [details]
Screenshot of Firefox location bar

Description of problem:
The new Cinnamon theme (which got updated by default) makes it difficult to read the input and select box controls in Mozilla Firefox. The location bar is also hardly readable. This issue occurred soon after the last Cinnamon upgrade. See the two screenshots from Fedora 25.

Version-Release number of selected component (if applicable):
cinnamon-settings-daemon-3.2.1-1.fc25.x86_64
cinnamon-control-center-filesystem-3.2.1-1.fc25.x86_64
cinnamon-session-3.2.0-1.fc25.x86_64
cinnamon-translations-3.2.2-1.fc25.noarch
imsettings-cinnamon-1.7.2-1.fc25.x86_64
cinnamon-control-center-3.2.1-1.fc25.x86_64
cinnamon-desktop-3.2.4-1.fc25.x86_64
cinnamon-menus-3.2.0-1.fc25.x86_64
cinnamon-screensaver-3.2.13-2.fc25.x86_64
cinnamon-3.2.8-11.fc25.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Login to Fedora 25 with Cinnamon as the DE
2. Open Firefox
3. Click on the location bar

Actual results:
The controls are unreadable

Expected results:


Additional info:
https://github.com/linuxmint/Cinnamon/issues/6262

Comment 1 Manilal 2017-02-10 13:20:48 UTC
Created attachment 1249036 [details]
Screenshot of a site's login box with values

Comment 2 leigh scott 2017-02-10 13:26:30 UTC
Firefox has had this issue for years


https://bugzilla.mozilla.org/show_bug.cgi?id=519763

Comment 3 Manilal 2017-02-10 13:38:13 UTC
Created attachment 1249040 [details]
Screenshot of Google Sheets on Firefox

Comment 4 leigh scott 2017-02-10 13:39:52 UTC
You could try this extension

https://addons.mozilla.org/en-GB/firefox/addon/text-contrast-for-dark-themes/

It adds an option to toggle text contrast.

Comment 5 Martin Stransky 2017-02-24 14:01:16 UTC
That's partially https://bugzilla.mozilla.org/show_bug.cgi?id=1158076 but I don't think Cinamon actually uses "dark" theme variant.

The fix would be enabled e10s + mozbz#1158076 + set default white theme for content process.

Comment 6 Christian Stadelmann 2017-03-26 10:15:52 UTC
And, of course, widget.allow-gtk-dark-theme should not be set to true.

Btw: With the new 52.0-6.fc25 build works around the bug in content process as described in comment #5, that's very nice. The urlbar is still barely readable because URLs are drawn in dark blue on dark gray. I've reported this separately, see bug #1435964.

Comment 7 Alexander Ploumistos 2017-03-27 15:34:29 UTC
(In reply to Christian Stadelmann from comment #6)
> And, of course, widget.allow-gtk-dark-theme should not be set to true.
> 
> Btw: With the new 52.0-6.fc25 build works around the bug in content process
> as described in comment #5, that's very nice. The urlbar is still barely
> readable because URLs are drawn in dark blue on dark gray. I've reported
> this separately, see bug #1435964.

Thanks, I hadn't thought to make that distinction.

Comment 8 Manilal 2017-03-30 06:18:09 UTC
Created attachment 1267413 [details]
Screenshot of Firefox location bar - Fixed

Comment 9 Manilal 2017-03-30 06:32:34 UTC
Created attachment 1267421 [details]
Screenshot of login page - fixed

Comment 10 Manilal 2017-03-30 06:33:34 UTC
Created attachment 1267423 [details]
Screenshot of Google Sheet - Fixed

Comment 11 Manilal 2017-03-30 06:36:08 UTC
I upgraded to firefox-52.0-7.fc25.x86_64 and the issue is fixed. Please see the screenshots in the new version.

Comment 12 Christian Stadelmann 2017-04-24 12:20:01 UTC
(In reply to Manilal from comment #11)
> I upgraded to firefox-52.0-7.fc25.x86_64 and the issue is fixed. Please see
> the screenshots in the new version.

Thanks for reporting back. I can confirm this fix. Can you please close this bug report as fixed? There are buttons for doing so below the answer text field.


Note You need to log in before you can comment on or make changes to this bug.