Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1421232 - [RFE] add option for 'verify packages and sync' for yum repos
Summary: [RFE] add option for 'verify packages and sync' for yum repos
Keywords:
Status: CLOSED DUPLICATE of bug 1223023
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Repositories
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-10 16:51 UTC by Justin Sherrill
Modified: 2017-04-25 16:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-17 22:40:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Justin Sherrill 2017-02-10 16:51:47 UTC
Description of problem:

For yum repos sometimes content on the filesystem becomes corrupt or missing.  Pulp provides the ability to do this but katello needs to support it.

katello would need to:

1) switch the repo to on_demand if its immediate (possibly just in pulp)
2) sync the repo
3) kick off a 'download' task with verify_all_units set to true
4) change the repo back to 'immediate' if needed 


more info:


https://docs.pulpproject.org/user-guide/deferred-download.html#re-using-files-on-disk-when-db-is-lost

Comment 4 Justin Sherrill 2017-02-17 22:24:14 UTC
Not entirely.  I think we need some design around this.  There are two different scenarios here:

a) You want to force pulp to sync the repository again, but pulp doesn't think it needs to so it just skips most of the steps.  Lets call this force sync.

b) There is some rpm corruption and you want pulp to verify all of the checksums locally on the filesytem and redownload anything that is corrupt.  Lets call this Repair and Sync


I know of three bzs that cover these situations I believe:

a) Force Sync
https://bugzilla.redhat.com/show_bug.cgi?id=1421250

b) Repair and Sync
https://bugzilla.redhat.com/show_bug.cgi?id=1421232
https://bugzilla.redhat.com/show_bug.cgi?id=1223023


And it is possible that we could combine both of these into one user action, however i imagine b) will take quite a bit longer, is quite a bit more complex, and likely won't be needed as much as a) (in my experience).  So I think This is a dupe of 1223023

I will close this BZ and retitle 1223023 accordingly.

Comment 5 Justin Sherrill 2017-02-17 22:40:15 UTC

*** This bug has been marked as a duplicate of bug 1223023 ***


Note You need to log in before you can comment on or make changes to this bug.