Bug 1421424 - RHVH installation failed due to "Not using lvmetad because duplicate PVs were found."
Summary: RHVH installation failed due to "Not using lvmetad because duplicate PVs were...
Keywords:
Status: CLOSED DUPLICATE of bug 1374545
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Douglas Schilling Landgraf
QA Contact: dguo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-12 08:56 UTC by Tareq Alayan
Modified: 2017-02-14 14:11 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-14 14:11:07 UTC
oVirt Team: Node
talayan: devel_ack?
talayan: testing_ack?


Attachments (Terms of Use)
logs-engine-and-host-deploy (537.86 KB, text/plain)
2017-02-12 08:56 UTC, Tareq Alayan
no flags Details
engine-log-after-going-up (519.60 KB, text/plain)
2017-02-12 09:07 UTC, Tareq Alayan
no flags Details
multipath.conf (1016 bytes, text/plain)
2017-02-12 14:50 UTC, Tareq Alayan
no flags Details
sosreport (9.58 MB, application/x-xz)
2017-02-12 15:07 UTC, Tareq Alayan
no flags Details

Description Tareq Alayan 2017-02-12 08:56:33 UTC
Created attachment 1249466 [details]
logs-engine-and-host-deploy

Description of problem:
Installation failed when adding a RHVH host to engine

Version-Release number of selected component (if applicable):
lvm2-2.02.166-1.el7_3.2.x86_64
rhvh-4.1-0.20170208.0+1
rhevm-4.1.1-0.1.el7.noarch

How reproducible:
always 

Steps to Reproduce:
1. add host to engine 
2.
3.

Additional info:
when running nodectl check on the rhvh: 
nodectl check 
  WARNING: Not using lvmetad because duplicate PVs were found.
  WARNING: Use multipath or vgimportclone to resolve duplicate PVs?
  WARNING: After duplicates are resolved, run "pvscan --cache" to enable lvmetad.
  WARNING: Not using lvmetad because duplicate PVs were found.
  WARNING: Use multipath or vgimportclone to resolve duplicate PVs?
  WARNING: After duplicates are resolved, run "pvscan --cache" to enable lvmetad.
Status: OK
Bootloader ... OK
  Layer boot entries ... OK
  Valid boot entries ... OK
Mount points ... OK
  Separate /var ... OK
  Discard is used ... OK
Basic storage ... OK
  Initialized VG ... OK
  Initialized Thin Pool ... OK
  Initialized LVs ... OK
Thin storage ... OK
  Checking available space in thinpool ... OK
  Checking thinpool auto-extend ... OK
vdsmd ... OK



Error message when adding host to engine:
Host host_mixed_1 installation failed. Unexpected error during execution:   WARNING: Not using lvmetad because duplicate PVs were found.
  WARNING: Use multipath or vgimportclone to resolve duplicate PVs?
  WARNING: After duplicates are resolved, run "pvscan --cache" to enable lvmetad.
  WARNING: PV XYkciU-t8a1-4xes-MMxV-4JU4-Pk9p-SMdL3g on /dev/sde was already found on /dev/sdq.
  WARNING: PV 2F5M5l-FBtj-CIn2-DkBQ-t0nF-vQht-5lKSJ3 on /dev/sdu was already found on /dev/sdc.
  WARNING: PV EGLIwP-MF1V-WpCh-6ao0-UgEc-Lo1R-mwUj7e on /dev/sdf was already found on /dev/sdr.
  WARNING: PV lHYldI-gy3M-SNWs-aMWK-Xf9h-rhl7-S0uinT on /dev/sdv was already found on /dev/sdd.
  WARNING: PV BqQHUV-ysPy-tamX-ENOa-t8ZU-cfqi-7DOmnh on /dev/sdg was already found on /dev/sds.
  WARNING: PV XYkciU-t8a1-4xes-MMxV-4JU4-Pk9p-SMdL3g on /dev/sdw was already found on /dev/sdq.
  WARNING: PV EGLIwP-MF1V-WpCh-6ao0-UgEc-Lo1R-mwUj7e on /dev/sdx was already found on /dev/sdr.
  WARNING: PV 2F5M5l-FBtj-CIn2-DkBQ-t0nF-vQht-5lKSJ3 on /dev/sdi was already found on /dev/sdc.
  WARNING: PV BqQHUV-ysPy-tamX-ENOa-t8ZU-cfqi-7DOmnh on /dev/sdy was already found on /dev/sds.
.


deploying logs are attached

Comment 1 Tareq Alayan 2017-02-12 09:03:41 UTC
I go with Activate even that the status of host is installation failed, and the host became non operational.
"Host host_mixed_1 does not comply with the cluster golden_env_mixed_1 networks, the following networks are missing on host: 'ovirtmgmt'"

However i go to the network tab and simply drag the ovirtmgmt bridge to one of the up nics and then host goes up. 

logs attached.

Comment 2 Tareq Alayan 2017-02-12 09:07:13 UTC
Created attachment 1249467 [details]
engine-log-after-going-up

Comment 3 Tareq Alayan 2017-02-12 14:50:42 UTC
Created attachment 1249574 [details]
multipath.conf

Comment 4 Tareq Alayan 2017-02-12 15:07:11 UTC
Created attachment 1249588 [details]
sosreport

Comment 5 Douglas Schilling Landgraf 2017-02-13 04:12:34 UTC
Hi Edward, 

Do you mind to take a look in this one?

Could be similar to with the below report?
Bug 1418813 - ovirtmgmg not created on host provisioning 
https://bugzilla.redhat.com/show_bug.cgi?id=1418813

@Taleq, is this sosreport generated after you manage to make the host up right?

Comment 6 dguo 2017-02-13 06:46:25 UTC
Tareq,

Do you have any other specific steps before adding host to engine?

since I used the same version rhvh-4.1-0.20170208.0, rhevm-4.1.1-0.1.el7.noarch with you, tried several times, all can be added successfully. Also, I did found any nodectl check warning.

Comment 7 dguo 2017-02-13 06:47:36 UTC
(In reply to dguo from comment #6)
> Tareq,
> 
> Do you have any other specific steps before adding host to engine?
> 
> since I used the same version rhvh-4.1-0.20170208.0,
> rhevm-4.1.1-0.1.el7.noarch with you, tried several times, all can be added
> successfully. Also, I did found any nodectl check warning.

Also, I did not found any nodectl check warning.

Comment 8 Edward Haas 2017-02-13 07:55:04 UTC
(In reply to Douglas Schilling Landgraf from comment #5)
> Hi Edward, 
> 
> Do you mind to take a look in this one?
> 
> Could be similar to with the below report?
> Bug 1418813 - ovirtmgmg not created on host provisioning 
> https://bugzilla.redhat.com/show_bug.cgi?id=1418813

I have not seen anything special in the engine logs, except some communication problem with the host.
@Alona, could you please have a look as well? I may be missing something.

Comment 9 Tareq Alayan 2017-02-13 11:51:45 UTC
(In reply to Douglas Schilling Landgraf from comment #5)
> Hi Edward, 
> 
> Do you mind to take a look in this one?
> 
> Could be similar to with the below report?
> Bug 1418813 - ovirtmgmg not created on host provisioning 
> https://bugzilla.redhat.com/show_bug.cgi?id=1418813
> 
> @Taleq, is this sosreport generated after you manage to make the host up
> right?
 Tareq: YES

Comment 10 Tareq Alayan 2017-02-13 11:52:54 UTC
(In reply to dguo from comment #6)
> Tareq,
> 
> Do you have any other specific steps before adding host to engine?
> 
> since I used the same version rhvh-4.1-0.20170208.0,
> rhevm-4.1.1-0.1.el7.noarch with you, tried several times, all can be added
> successfully. Also, I did found any nodectl check warning.

I suppose you don't have iscsi storage attached to your hosts Dgou

Comment 11 Tareq Alayan 2017-02-13 11:54:38 UTC
accidentaily remove the needinfo from alkaplan. Just put it back.

Comment 12 Moran Goldboim 2017-02-14 08:49:04 UTC
Tareq, are you doing it through api call? can it be a dup of https://bugzilla.redhat.com/show_bug.cgi?id=1367107 ?

Comment 13 Moran Goldboim 2017-02-14 08:53:05 UTC
(In reply to Moran Goldboim from comment #12)
> Tareq, are you doing it through api call? can it be a dup of
> https://bugzilla.redhat.com/show_bug.cgi?id=1367107 ?

please disregard this comment - i was referring to a different bug

Comment 14 Ryan Barry 2017-02-14 14:11:07 UTC

*** This bug has been marked as a duplicate of bug 1374545 ***


Note You need to log in before you can comment on or make changes to this bug.