Bug 1421431 - Gnocchi on undercloud: "generic" resource is not created
Summary: Gnocchi on undercloud: "generic" resource is not created
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Mehdi ABAAKOUK
QA Contact: Sasha Smolyak
URL:
Whiteboard:
: 1422097 1422108 (view as bug list)
Depends On: 1434345 1434361
Blocks: 1422569
TreeView+ depends on / blocked
 
Reported: 2017-02-12 10:04 UTC by Sasha Smolyak
Modified: 2017-05-17 19:58 UTC (History)
7 users (show)

Fixed In Version: openstack-ceilometer-8.0.0-5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:58:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
RDO 5305 None None None 2017-02-17 09:14:51 UTC

Description Sasha Smolyak 2017-02-12 10:04:23 UTC
Description of problem:
When creating new "generic" resource with hw metrics assigned, it doesn't appear in 
gnocchi resource list

Version-Release number of selected component (if applicable):

openstack-gnocchi-api-3.1.0-0.20170126003150.2e0a43c.el7ost.noarch
python-gnocchi-3.1.0-0.20170126003150.2e0a43c.el7ost.noarch
openstack-gnocchi-metricd-3.1.0-0.20170126003150.2e0a43c.el7ost.noarch
python-gnocchiclient-2.8.2-0.20170118224916.f14fe0e.el7ost.noarch
openstack-gnocchi-common-3.1.0-0.20170126003150.2e0a43c.el7ost.noarch
openstack-gnocchi-statsd-3.1.0-0.20170126003150.2e0a43c.el7ost.noarch
openstack-gnocchi-indexer-sqlalchemy-3.1.0-0.20170126003150.2e0a43c.el7ost.noarch
puppet-gnocchiopenstack-ceilometer-notification-7.0.0-0.20170126113252.05f4d1b.el7ost.noarch

python-ceilometerclient-2.7.0-0.20161108104210.5328c31.el7ost.noarch
openstack-ceilometer-central-7.0.0-0.20170126113252.05f4d1b.el7ost.noarch
python-ceilometer-7.0.0-0.20170126113252.05f4d1b.el7ost.noarch
openstack-ceilometer-collector-7.0.0-0.20170126113252.05f4d1b.el7ost.noarch
openstack-ceilometer-api-7.0.0-0.20170126113252.05f4d1b.el7ost.noarch
openstack-ceilometer-polling-7.0.0-0.20170126113252.05f4d1b.el7ost.noarch
python-ceilometermiddleware-1.0.0-0.20161110151308.87bd49b.el7ost.noarch
openstack-ceilometer-common-7.0.0-0.20170126113252.05f4d1b.el7ost.noarch
puppet-ceilometer-10.1.0-0.20170123204213.e80d90d.el7ost.noarch
-10.1.0-0.20170121054618.765ff3f.el7ost.noarch



How reproducible:
100%

Steps to Reproduce:
1. Deploy RHOS11 undercloud with enable_telemetry=true in undercloud.conf
2. Edit /etc/ceilometer/pipeline.yaml:
---
sources:
    - name: hw_source
      interval: 60
      meters:
          - "hardware.cpu.load.1min"
          - "hardware.cpu.load.5min"
          - "hardware.cpu.load.15min"
      sinks:
          - meter_sink
3.  Assert gnocchi_resources.yaml has next snippet:
  - resource_type: generic
    metrics:
      - 'hardware.cpu.load.1min'
      - 'hardware.cpu.load.5min'
      - 'hardware.cpu.load.15min'

4.  Restart services
systemctl restart \
openstack-ceilometer-notification.service \ openstack-ceilometer-collector.service \
openstack-ceilometer-central.service

5. After several minutes run  gnocchi resource list

Actual results:
No new "generic" resource appears. The existing one (there is one generic metric in the list) doesn't have the metrics:

[stack@undercloud-0 ~]$ gnocchi resource list | grep generic
| 0a8b55df-f90f-491c-8cb9-7cdecec6fc26 | generic                | None                             | None                             | None                                                                                   | 2017-02-09T13:20:45.784945+00:00 | None     | 2017-02-09T13:20:45.784961+00:00 | None         |


[stack@undercloud-0 ~]$ gnocchi measures show --aggregation max --resource-id 0a8b55df-f90f-491c-8cb9-7cdecec6fc26 hardware.cpu.load.1min
Metric hardware.cpu.load.1min does not exist (HTTP 404)

Expected results:
1. The resource is created
2. It has the metrics
3. The metrics show results


Additional info:
When deploying without the parameter "enable_telemetry=true" and running all the steps the resource is created, but the command "gnocchi measures show --aggregation max --resource-id <ID> hardware.cpu.load.1min" returns empty line

Comment 1 Pradeep Kilambi 2017-02-14 15:28:03 UTC
*** Bug 1422097 has been marked as a duplicate of this bug. ***

Comment 2 Mehdi ABAAKOUK 2017-02-17 09:11:12 UTC
*** Bug 1422108 has been marked as a duplicate of this bug. ***

Comment 3 Mehdi ABAAKOUK 2017-02-17 09:14:30 UTC
ceilometer-central-agent was not starting correctly:

2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils [-] Unhandled exception
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils Traceback (most recent call last):
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils   File "/usr/lib/python2.7/site-packages/cotyledon/_utils.py", line 84, in exit_on_exception
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils     yield
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils   File "/usr/lib/python2.7/site-packages/cotyledon/_service.py", line 139, in _run
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils     self.run()
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils   File "/usr/lib/python2.7/site-packages/ceilometer/agent/manager.py", line 423, in run
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils     self.polling_manager = pipeline.setup_polling(self.conf)
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils   File "/usr/lib/python2.7/site-packages/ceilometer/pipeline.py", line 911, in setup_polling
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils     return PollingManager(conf, cfg_file)
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils   File "/usr/lib/python2.7/site-packages/ceilometer/pipeline.py", line 889, in __init__
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils     self.sources.append(PollingSource(s))
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils   File "/usr/lib/python2.7/site-packages/ceilometer/pipeline.py", line 362, in __init__
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils     raise PipelineException("Missing interval value", cfg)
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils PipelineException: Pipeline {'meters': ['*'], 'name': 'meter_source', 'sinks': ['meter_sink']}: Missing interval value
2017-02-16 16:35:02.044 32413 ERROR cotyledon._utils
2017-02-16 16:35:02.054 19392 INFO cotyledon._service_manager [-] Child 32413 exited with status 2

This is due to a missing configuration recently introduced /etc/ceilometer/polling.yaml.

This will be fixed in packaging: https://review.rdoproject.org/r/#/c/5305/

Comment 5 Sasha Smolyak 2017-03-13 09:03:26 UTC
As of yet, the rpm is not in the latest puddle (of 08.03.2017). Waiting for the rpm to enter the puddle

Comment 7 Sasha Smolyak 2017-04-09 12:46:42 UTC
openstack-ceilometer-polling-8.0.1-1.el7ost.noarch
openstack-ceilometer-central-8.0.1-1.el7ost.noarch
openstack-ceilometer-api-8.0.1-1.el7ost.noarch
openstack-ceilometer-collector-8.0.1-1.el7ost.noarch
openstack-ceilometer-common-8.0.1-1.el7ost.noarch
openstack-ceilometer-notification-8.0.1-1.el7ost.noarch

After performing the original scenario the new generic resource on undercloud is not created.

No errors in collector.log
The only error in central.log:
ERROR ceilometer.agent.manager [-] Skipping volume_snapshots, keystone issue: public endpoint for volumev3 service in regionOne region not found

Comment 10 errata-xmlrpc 2017-05-17 19:58:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.