Bug 142154 - DBS: CONFIG_X86_SPEEDSTEP_CENTRINO=m on 2.6.9-1.860 x86_64 kernel
DBS: CONFIG_X86_SPEEDSTEP_CENTRINO=m on 2.6.9-1.860 x86_64 kernel
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: 135876
  Show dependency treegraph
 
Reported: 2004-12-07 13:03 EST by Matt Domsch
Modified: 2015-01-04 17:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 07:29:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2004-12-07 13:03:51 EST
Description of problem:
$subject.  It should be =y (as it is for x86).

Version-Release number of selected component (if applicable):
2.6.9-1.860
Comment 3 Jason Baron 2004-12-07 15:27:59 EST
I'm closing this bug as we've agreed for GA to disable the speedstep
centrino driver. We'll use 138952, to track the progress of this
feature in U1, since it has all of the history already.
Comment 4 Matt Domsch 2004-12-07 17:19:18 EST
Duh, right, I agree it should be disabled, not =y, my mistake.
Can we leave this open, mark MODIFIED when the change is committed to CVS?
Comment 5 Jason Baron 2004-12-07 17:24:49 EST
right, two changes needed to be made from rc1:

1) disable CENTRINO on x86_64, captured now in this bug
2) enable ACPI_CPUFREQ=y on x86_64, per bz #142152

This should now be committed, but i'll let Dave move it to modified.
Comment 6 Dave Jones 2004-12-07 20:37:29 EST
been thinking about this situation.  I think building ACPI in is going
to break every other cpufreq driver, as cpufreq only supports 1 driver
right now, and acpi is going to claim success on a majority of
hardware, including hardware that for eg, may be better suited with
powernow drivers or such.

This might be fixable just by adjusting the link order.
Comment 7 Matt Domsch 2004-12-07 20:55:25 EST
The acpi driver will load after everything except p4_clockmod as it is
currently built based on load order, assuming all the other drivers
are built-in, and it looks like it's "first one that works wins".
Comment 8 Dave Jones 2004-12-07 21:04:58 EST
yes, that'll teach me to check the code before making comments. :-)

p4-clockmod isn't too useful anyway, so the current status seems fine.
Comment 10 Jay Turner 2004-12-09 07:29:35 EST
2.6.9-1.871_EL has the following:

kernel-2.6.9-i686.config:# CONFIG_X86_SPEEDSTEP_CENTRINO is not set
kernel-2.6.9-i686-hugemem.config:# CONFIG_X86_SPEEDSTEP_CENTRINO is not set
kernel-2.6.9-i686-smp.config:# CONFIG_X86_SPEEDSTEP_CENTRINO is not set
kernel-2.6.9-x86_64.config:# CONFIG_X86_SPEEDSTEP_CENTRINO is not set
kernel-2.6.9-x86_64-smp.config:# CONFIG_X86_SPEEDSTEP_CENTRINO is not set
kernel-2.6.9-i686.config:CONFIG_X86_ACPI_CPUFREQ=y
kernel-2.6.9-i686-hugemem.config:CONFIG_X86_ACPI_CPUFREQ=y
kernel-2.6.9-i686-smp.config:CONFIG_X86_ACPI_CPUFREQ=y
kernel-2.6.9-x86_64.config:CONFIG_X86_ACPI_CPUFREQ=y
kernel-2.6.9-x86_64-smp.config:CONFIG_X86_ACPI_CPUFREQ=y

So, that's what's mentioned in comment 5 and since this kernel is included in
our latest trees, closing out.

Note You need to log in before you can comment on or make changes to this bug.