Bug 1421648 - [UPDATES] Updates process attempts to start on all controllers concurently
Summary: [UPDATES] Updates process attempts to start on all controllers concurently
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Toure Dunnon
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-13 10:52 UTC by Yurii Prokulevych
Modified: 2017-05-17 19:59 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-common-5.8.1-0.20170301225725.88a547f.el7ost.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:59:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Yurii Prokulevych 2017-02-13 10:52:22 UTC
Description of problem:
-----------------------
Attempt to update failed with a message:
[DEBUG] Error: Stopping the node will cause a loss of the quorum, use --force to override
[ERROR] Error running /var/lib/heat-config/heat-config-script/c3bdb14e-6c0b-48a9-96c6-0bd7cb9ecf9f. [1]
[INFO] Completed /usr/libexec/heat-config/hooks/script

At the same time update was already running on another controller node.

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
openstack-tripleo-heat-templates-6.0.0-0.20170127041112.ce54697.el7ost.1.noarch
openstack-heat-templates-0.0.1-0.20170124165609.15cf0b6.el7ost.noarch

python-openstack-mistral-4.0.0-0.20170126231245.47efc0f.el7ost.noarch
openstack-mistral-engine-4.0.0-0.20170126231245.47efc0f.el7ost.noarch
openstack-mistral-api-4.0.0-0.20170126231245.47efc0f.el7ost.noarch
openstack-mistral-common-4.0.0-0.20170126231245.47efc0f.el7ost.noarch
puppet-mistral-10.1.0-0.20170123224219.22afb8b.el7ost.noarch
openstack-mistral-executor-4.0.0-0.20170126231245.47efc0f.el7ost.noarch
python-mistralclient-3.0.0-0.20170120193250.a7bf138.el7ost.noarch


Steps to Reproduce:
1. Install RHOS-11 puddle 2017-02-01.2
2. Setup latest RHOS-11 repos
3. Update undercloud
4. Try to update overcloud

Actual results:
---------------
yes '' | openstack overcloud update stack -i overcloud
Started Mistral Workflow tripleo.package_update.v1.package_update_plan. Execution ID: 1270370f-408c-4ee3-8e22-dd462e42cfe6
Waiting for messages on queue 'ddfd6d25-15ac-4915-8370-803f916c44a8' with no timeout.
IN_PROGRESS
IN_PROGRESS
FAILED
update finished with status FAILED
Stack update failed.

Additional info:
----------------
Virtual setup: 3controllers + 1compute + 3ceph

Comment 4 Yurii Prokulevych 2017-04-07 13:28:24 UTC
Update succeeded with openstack-tripleo-common-6.0.0-6.el7ost.noarch

Comment 5 errata-xmlrpc 2017-05-17 19:59:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.