Bug 1421819 - rgw: change loglevel to 20 for 'System already converted' message
Summary: rgw: change loglevel to 20 for 'System already converted' message
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 2.3
Assignee: Vikhyat Umrao
QA Contact: Vidushi Mishra
Erin Donnelly
URL:
Whiteboard:
Depends On:
Blocks: 1437916
TreeView+ depends on / blocked
 
Reported: 2017-02-13 18:40 UTC by Vikhyat Umrao
Modified: 2020-03-11 15:47 UTC (History)
11 users (show)

Fixed In Version: RHEL: ceph-10.2.7-6.el7cp Ubuntu: ceph_10.2.7-7redhat1xenial
Doc Type: Bug Fix
Doc Text:
.The radosgw-admin utility no longer logs an unnecessary message Previously, the `radosgw-admin` utility logged the following message every time even if the message was not relevant: ---- `2017-02-11 00:09:56.704029 7f9011d259c0 0 System already converted` ---- The log level of this message has been changed from 0 to 20. As a result, the `radosgw-admin` command logs the aforementioned message only when appropriate.
Clone Of:
Environment:
Last Closed: 2017-06-19 13:29:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 18919 0 None None None 2017-02-13 18:41:41 UTC
Red Hat Knowledge Base (Solution) 2922351 0 None None None 2017-02-13 22:46:12 UTC
Red Hat Product Errata RHBA-2017:1497 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC

Description Vikhyat Umrao 2017-02-13 18:40:02 UTC
Description of problem:
rgw: change loglevel to 20 for 'System already converted' message

Upstream tracker: http://tracker.ceph.com/issues/18919


Version-Release number of selected component (if applicable):
Red Hat Ceph Storage 2.1
10.2.3-17.el7cp

How reproducible:
Always

- If we upgrade hammer to jewel and metadata gets converted successfully from hammer to jewel, we log a message:

~~~
2017-02-11 00:09:56.704029 7f9011d259c0  0 System already converted 
~~~

- Now because this log message is at log level 0, it is getting printed in each and every simple 'radosgw-admin' command:

~~~
# radosgw-admin user info --uid testuser
2017-02-11 00:09:56.704029 7f9011d259c0  0 System already converted 
{
    "user_id": "testuser",
    "display_name": "Test User1",
    "email": "",
~~~

Comment 2 Vikhyat Umrao 2017-02-17 20:51:54 UTC
Master branch PR: https://github.com/ceph/ceph/pull/13399

Comment 21 errata-xmlrpc 2017-06-19 13:29:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.