Bug 1422428 - [fr-FR] Admin portal->Quota: measurements units are mixed up (GB in English and Go in French all mixed up).
Summary: [fr-FR] Admin portal->Quota: measurements units are mixed up (GB in English a...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.3
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.3.4
: ---
Assignee: Andrej Krejcir
QA Contact: Jan Zmeskal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-15 10:31 UTC by Krishna Babu K
Modified: 2019-11-06 08:38 UTC (History)
12 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2019-06-11 06:24:05 UTC
oVirt Team: SLA
akrejcir: needinfo-
dfediuck: ovirt-4.3+
mgoldboi: planning_ack+
rule-engine: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)
Quota-storage mixed translation entry (116.82 KB, image/png)
2017-02-15 10:31 UTC, Krishna Babu K
no flags Details
French translation with inconsistent units is not fixed (214.98 KB, image/png)
2017-04-27 22:14 UTC, Yuko Katabami
no flags Details
Failed verification in RHV 4.2.8 (34.25 KB, image/png)
2018-12-11 15:27 UTC, Jan Zmeskal
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 74049 0 'None' MERGED webadmin: Add memory units to ApplicationMessages 2021-01-11 08:53:48 UTC
oVirt gerrit 74407 0 'None' MERGED webadmin: Add memory units to ApplicationMessages 2021-01-11 08:53:10 UTC
oVirt gerrit 90533 0 'None' MERGED webadmin: Change unit labels in quota dialog from MB and GB to MiB and GiB 2021-01-11 08:53:10 UTC
oVirt gerrit 91385 0 'None' MERGED webadmin: Change unit labels in quota dialog from MB and GB to MiB and GiB 2021-01-11 08:53:48 UTC

Description Krishna Babu K 2017-02-15 10:31:17 UTC
Created attachment 1250544 [details]
Quota-storage mixed translation entry

Description of problem:
  In System->Data Centers->Quota->Storage: measurements units are mixed up (GB in English and Go in French all mixed up). We need to choose one only. The English should be OK, but not mixing them..(eg: 1 GB parmi une quantité illimitée en Go). Needs to replace all 'GB' (Gigabytes) by Go' (Gigaoctets)

Version-Release number of selected component (if applicable):
4.1.0.3-0.1.el7

How reproducible:
always

Steps to Reproduce:
1. Log into ovirt-engine admin portal with fr_FR locale
2. Navigate to System->Data centers->Quota->Storage
3. Observe the string mentioned in description

Actual results:
'GB'(Gigabytes) and 'GO'(Gigaoctets) are mixed in single translation entry.

Expected results:
Needs to replace all 'GB' (Gigabytes) by Go' (Gigaoctets)

Additional info:
Translator comments on this issue:
http://i18n-qe.lab.eng.pnq.redhat.com/~kkrothap/admin-portal-quota-TestCase.pdf

Comment 1 Red Hat Bugzilla Rules Engine 2017-02-16 10:55:34 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Yuko Katabami 2017-04-27 22:13:43 UTC
Not sure why this is on QA status.
The translation is unchanged in Admin Portal 4.1.1.8-0.1.el7 (see screenshot).
In Zanata:
source: "{0} out of unlimited GB".
translation: {0} sur une quantité illimitée en Go

I think the problem is that the variable "{0}" contains the unit in English.
If it only contains the value, then the translator is able to translate the unit and will become consistent.

Also, we cannot just change the unit in this particular string.
It seems that all GBs are translated into Go for French in oVirt project.

Comment 3 Yuko Katabami 2017-04-27 22:14:30 UTC
Created attachment 1274798 [details]
French translation with inconsistent units is not fixed

Comment 4 Yuko Katabami 2017-04-27 22:19:45 UTC
Ccing Corina -- our French Language Specialist

Comment 5 Andrej Krejcir 2017-04-28 09:25:32 UTC
This bug is not yet fixed in 4.1.1.8. It was targeted to 4.1.2.

The fix adds translatable units instead of hard-coded strings in the engine.

Comment 6 croe@redhat.com 2017-05-01 23:49:39 UTC
'the fix adds translatable units instead of hard-coded strings in the engine.'

In this particular case, as indicated in the QA, we could change it all to GB but the problem is pervasive to variable in general - than you for your diligent attention

Comment 7 Yuko Katabami 2017-05-15 10:36:47 UTC
Hi Andrej,

Thank you very much for your response.
I am changing the status back to POST.

Comment 8 Red Hat Bugzilla Rules Engine 2017-05-15 10:36:55 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 9 Yuko Katabami 2017-07-02 11:35:47 UTC
Unable to QA until:
1. the updated string is pushed to Zanata
2. we translate it
3. translation is pulled and imported into the code
4. check it on a test environment.

What can I do win the status?

Comment 10 Sandro Bonazzola 2017-08-03 14:39:04 UTC
(In reply to Yuko Katabami from comment #9)
> Unable to QA until:
> 1. the updated string is pushed to Zanata
> 2. we translate it
> 3. translation is pulled and imported into the code
> 4. check it on a test environment.
> 
> What can I do win the status?

I think this should fail QE if the translation is not in zanata and in 4.1.3

Comment 11 Yuko Katabami 2017-08-03 22:17:38 UTC
Thanks Sandro.
So what should I do with the status?
Moving back to POST?

Comment 12 Martin Sivák 2017-08-23 10:23:44 UTC
Yuko, can you please check whether the strings are translatable in Zanata for 4.1.3? The old one was not modified iirc, but there are new strings for the units to translate ("gb" for example).

Comment 13 Yuko Katabami 2017-08-23 10:54:50 UTC
Hi Martin,

The updated string is not yet pushed to Zanata and it remains "{0} out of unlimited GB".
This is because we have not started the translation cycle.

The localization key dates are not yet scheduled, but I expect the first cycle will be around mid October.
Would it be OK for me to check it after that?

Comment 14 Bhushan Barve 2017-09-12 12:30:43 UTC
As per #comment 13, the string is not yet pushed to Zanata as there is no translation cycle planned for 4.1.5/6. So not available with 4.1.6 when checked currently. The next translation cycle will be for 4.2. So would be better if it is marked for 4.2

Comment 15 Bhushan Barve 2018-04-05 12:08:56 UTC
Checked with 4.2.2.4-0.1.el7

Still the units are mixed-up as-
10 GiB sur une quantité illimitée en Go

Are the updated translations are available is zanata as per comment #12 and #13?

Currently for fr_FR it is as follows in zanata-
{0} out of unlimited GB -> {0} sur une quantité illimitée en Go

Moving it back to assigned.

Comment 16 Red Hat Bugzilla Rules Engine 2018-04-05 12:09:04 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 17 Andrej Krejcir 2018-04-17 09:16:42 UTC
The patches in this bug make the units localizable.

In another Bug 1535714, the units are changed from GB to GiB, but not in all places. The quota messages are not changed, that is why there are combined units GiB and GB in one message.

Comment 18 Raz Tamir 2018-08-26 10:14:45 UTC
Hi,

Can this be verified?

Comment 19 Jan Zmeskal 2018-12-11 15:27:37 UTC
Created attachment 1513433 [details]
Failed verification in RHV 4.2.8

Comment 20 Jan Zmeskal 2018-12-11 15:34:53 UTC
Verification steps:

1. Switch webadmin's language to French
2. Go to Administration -> Quota. Select one of the quotas (might be the default unlimited one) and click it. 
3. Go to "Stockage" tab.

Result: The used units are still inconsistent. It says "70 GiB sur une quantité illimitée en Go".
See attachment 1513433 [details]

Verification failed on: 
rhvm-4.2.8-0.1.el7ev.noarch

Comment 21 Andrej Krejcir 2018-12-11 16:04:27 UTC
It seems that the strings are not translated.

The localizable strings for size unit constants are in 'CommonApplicationMessages.properties',
but they are not in the translated files like 'CommonApplicationMessages_fr_FR.properties'.

Are they translated in Zanata?

These are the messages in CommonApplicationMessages.properties:
gibibytes={0} GiB
mebibytes={0} MiB

Comment 22 Sandro Bonazzola 2019-01-28 09:40:17 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 23 Andrej Krejcir 2019-05-10 14:05:28 UTC
I see the translations were added in version 4.3.0

Comment 24 Jan Zmeskal 2019-05-22 09:53:18 UTC
Verified on 4.3.4-0.1.el7 using verification steps from comment #20.

Comment 25 Sandro Bonazzola 2019-06-11 06:24:05 UTC
This bugzilla is included in oVirt 4.3.4 release, published on June 11th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.