Bug 1422642 - [RFE] As a deployer, I want the application to auto-discover locally attached storage details. Disks, Type, Controller, Size, Device Name, Topology, RAID, Vendor, Firmware rev
Summary: [RFE] As a deployer, I want the application to auto-discover locally attached...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: Upstream M3
: 12.0 (Pike)
Assignee: RHOS Maint
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks: 1442136 1420921 1469872
TreeView+ depends on / blocked
 
Reported: 2017-02-15 18:20 UTC by Anandeep Pannu
Modified: 2018-02-05 19:04 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-ui-7.1.1-0.20170707120659.69b30f7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 21:08:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 467872 0 None None None 2017-07-06 22:47:22 UTC
OpenStack gerrit 471318 0 None None None 2017-07-06 22:48:28 UTC
OpenStack gerrit 472264 0 None None None 2017-07-06 22:48:08 UTC
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Anandeep Pannu 2017-02-15 18:20:09 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Anandeep Pannu 2017-05-03 14:12:48 UTC
For the UI the following will be needed
1. Ability to connect to the capabilities for auto-discovery provided by the H/W DFG - specific to storage details 
2. Auto-introspection of the nodes and get storage details
3. Display of the nodes data (wireframe here https://openstack.invisionapp.com/share/247VLM4SB#/screens/164572258_2016-6-6_TripleO_UI32 ) 
4. Introspection and other steps in the workflow remain the same 

At this time we should still be able to use either auto-discover or upload nodes.json

Comment 4 Jason E. Rist 2017-07-06 22:47:22 UTC
All 3 merged

Comment 10 Ola Pavlenko 2017-11-27 19:04:23 UTC
The feature is an exposure of ironic node data for devices in a dedicated modal on UI.
The RFE was tested with the default internal storage devices and with HW RAID.
The RFE doesn't relate to an auto-discovery ironic-inspector rfe https://bugzilla.redhat.com/show_bug.cgi?id=1362361

Comment 13 errata-xmlrpc 2017-12-13 21:08:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.