Bug 142292 - Current combination of mpage-2.5.4-2 and ghostscript-7.07-33 produces bad postscript
Current combination of mpage-2.5.4-2 and ghostscript-7.07-33 produces bad pos...
Status: CLOSED DUPLICATE of bug 139798
Product: Fedora
Classification: Fedora
Component: mpage (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2004-12-08 14:46 EST by Hardy Mayer
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-09 07:27:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Hardy Mayer 2004-12-08 14:46:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)

Description of problem:
After the fc-3 update mpage stopped working.  The typical postcript
error in the files produced, e.g, by running ps2pdf on the output,  is: 
Error: /undefinedresource in --findresource--
Operand stack:
   unijis   Ryumin-Light-UniJIS-UTF8-H   Font  
Ryumin-Light-UniJIS-UTF8-H   (Ryumin-Light-UniJIS-UTF8-H)   12  
Ryumin-Light  UniJIS-UTF8-H   UniJIS-UTF8-H   --dict:0/10(G)--  
Ryumin-Light   false   Ryumin-Light   Ryumin-Light   CIDFont  
--nostringval--   CMap   CIDFont   CMap   CIDFont
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--  
--nostringval--   --nostringval--   false   1   %stopped_push   1   3
  %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop  1   3  
%oparray_pop   .runexec2   --nostringval--   --nostringval--  
--nostringval--   2   %stopped_push   --nostringval--  2   3  
%oparray_pop   3   3   %oparray_pop   --nostringval--  
--nostringval--   16   4   %oparray_pop   --nostringval--   19   5  
%oparray_pop   --nostringval--   --nostringval--   --nostringval--  
Dictionary stack:
   --dict:1063/1123(ro)(G)--   --dict:0/20(G)--   --dict:100/200(L)--
  --dict:17/17(ro)(G)--   --dict:0/10(L)--   --dict:16/24(ro)(G)--
Current allocation mode is local
Last OS error: 2
Current file position is 4187
GNU Ghostscript 7.07: Unrecoverable error, exit code 1

I tried installing the japanese tt-fonts, but this did not help. 

Version-Release number of selected component (if applicable):
mpage-2.5.4-2 and ghostscript-7.0.7-33

How reproducible:

Steps to Reproduce:
1.produce a postscript file (e.g. by printing to file from Mozilla, or
running dvips on a LaTeX file. 
2. invoke, e.g., mpage file1.ps > file2.ps
3. rune either ps2pdf file2.ps or gv file2.ps and your will get the
above ghostscript error.

Actual Results:  The error message mentioned above. 

Expected Results:  A n-up postscript file which can be printed,
previewed, or converted to pdf. 

Additional info:

I also tried compiling a clean version of mpage-2.5.4, and
ghostscript-8.14 and get similar incompatibilities
Comment 1 Tim Waugh 2004-12-09 07:27:01 EST

*** This bug has been marked as a duplicate of 139798 ***

Note You need to log in before you can comment on or make changes to this bug.